Packaging Game UE 4.3 (Preview) Errors

I’m having an issue that I can’t figure out even after reading multiple issues related to mine here on AnswerHub. I currently run 4.3 preview from source and was trying to package my game for Windows 64-Bit. I compiled the engine as “Development Editor” & “Development” (after finding out about the error from Development Editor) on x64. When I package the game I keep getting the same AutomationTool that everyone else gets related to the issue. I’m currently running Windows 8.1 with Nvidia GTX 780ti and never had this issue before. My project is also a third person C++ code project. When I build the project I use “DebugGame Editor” which I then launch to editor to do what I need to do work wise.

Below is the error I get in the output log showing failed to build package. Any thoughts?

MainFrameActions: Packaging (Windows (64-bit)): ProcessManager.KillAll: Trying to kill 0 spawned processes.
MainFrameActions: Packaging (Windows (64-bit)): AutomationToolLauncher exiting with ExitCode=1
MainFrameActions: Packaging (Windows (64-bit)): copying UAT log files…
MainFrameActions: Packaging (Windows (64-bit)): RunUAT.bat ERROR: AutomationTool was unable to run successfully.
MainFrameActions: Packaging (Windows (64-bit)): BUILD FAILED
LogSlate: SRTH: 000000C9B956A740, 1136 x 672, prev 0000000000000000

Could you attach the full log below so we can see it in its entirety?

Unreal Engine\4.3\Engine\Programs\AutomationTool\Saved\Logs\UAT_Logs.txt

Sure I uploaded to Google Drive. Here is the link.

It seems you have this error:

LogPackageName:Error: DoesPackageExist: DoesPackageExist FAILED: ‘None’ is not a standard unreal filename or a long path name. Reason: Path should start with a '/'

From what I have seen in another AnswerHub thread, this could be related to the GameMode being set to None. Try go to Project Settings / Maps and Modes / Default Modes, then set Default Game Mode and Global Default Server Game Mode (under the arrow) to any other game mode than none.

Try build again after that. It is a long shot, but hopefully it is just this.

Mine was not set to none it was set to my assigned (PackageGameMode) file. I changed it as well and still getting the same error. Can’t quite figure it out.

Did you change both of them? (server as well)

How do I change the server?


Just changed the server didn’t see the drop down arrow. Currently packaging for X64 Windows and will update here in about 5 minutes after packaging is complete.

[EDIT #2]

You fixed it Denny! Thank you very much kind sir!

I had a similar problem. After upgrading from 4.2 to 4.3 I could no longer package my project. After setting Global Default Server Game Mode to something else than None, ( also recompiled everything just in case) it worked out great!

Thanks alot for the solution!


Thank you for your report. We were not able to investigate this on the engine version you reported, but there have been many version changes to UE4 since this question was first posted. With a new version of the Engine comes new fixes and it is possible that this issue has changed or may no longer occur. Due to timetable of when this issue was first posted, we are marking this post as resolved for tracking purposes. If you are still experiencing the issue you reported in the current engine version, then please respond to this message with additional information and we will investigate as soon as possible. If you are experiencing a similar, but different issue at this time, could you please submit a new report for it.