Packaging for win64 not working UATHelper: Packaging (Windows): ERROR: System.Exception: Found no script module records. [UE5.0]

hello i am currently building a game using the lyra starter project in ue5 btw, but when i go to packedge the project i get a warning “sdk for windows is not installed properly”
then i hit continue an i get this error “UATHelper: Packaging (Windows): ERROR: System.Exception: Found no script module records.”


Having the same issue. Did you find a solution?

We had same problem on our project. Go to: YourProjectName\Build\Scripts folder and check if there is YourProjectName.Automation C# project file and if there is Automation folder there.

i dont know what fixed(think its because i reinstalled all the sdks i would need lol) it but yeah just worked one day(does not work anymore)

The issue for me was related to my use of the -NoCompile flag.
It was looking for an existing editor exe and failing.
I had to tell it which editor exe to use.

Removing the -NoCompile flag led to a new error about not finding UnrealEditor-Cmd.exe (I compiled the editor using the DebugGame config).

Finally, I added the -NoCompile flag back in alongside -UnrealExe=“UnrealEditor-Win64-DebugGame-Cmd.exe” and it worked fine.