Packaging for linux (on win) fails

Hey everyone.

I’ve been struggling with this one for two days now. I see a lot of similar issues that other people are having, but I can’t seem to find a solution that works.

I have been following this tutorial:

Along with some other help threads where people are having issues.

I can compile (in VS) and I have linux executables, but I cannot get the package step to complete.

Package step error log is here:

I saw some others had this same issue, and the solution they found was to “build ue4 in ‘development’ ‘linux’ mode”. This is failing for me too:

Severity	Code	Description	Project	File	Line	Suppression State
Error		linker command failed with exit code 1 (use -v to see invocation)	UE4	F:\Unreal Projects\MMDEMO1\Intermediate\ProjectFiles\clang++.exe	1	
Error		Failed to produce item: F:\ue4github\UnrealEngine\Engine\Binaries\Linux\UE4Game	UE4	F:\Unreal Projects\MMDEMO1\Intermediate\ProjectFiles\ERROR	1	
Error	MSB3073	The command "F:\ue4github\UnrealEngine\Engine\Build\BatchFiles\Build.bat UE4Game Linux Development -waitmutex" exited with code -1.	UE4	C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V140\Microsoft.MakeFile.Targets	37	

Please help! I’m so close!!!

Update: I was able to complete the “build ue4 development linux” step. But I am still seeing this same error.

How can I get LinuxNoEditor to be available to package?

Fatal error: [File:F:\ue4github\UnrealEngine\Engine\Source\Developer\TargetPlatform\Private\TargetPlatformManagerModule.cpp] [Line: 220]
Invalid target platform specified (LinuxNoEditor). Available = { AllDesktop, WindowsClient, WindowsNoEditor, WindowsServer, Windows, Android, Android_ASTC, Android_ATC, Android_DXT, Android_ETC1, Android_ETC2, Android_Multi, Android_PVRTC, HTML5, IOS }

is linux selected in target platforms

Thanks for the response Mulldoon!

Inside of VS, linux is there. Is there somewhere else to check?

It is also here. inside ue4. Anywhere else to check?

I am also seeing some conflicting instructions (now that i’ve gone through the process multiple times). For example:

This A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums page says after running the powershell script, and setting the environment variable, the next step is “re-regenerate UE4 project files (using GenerateProjectFiles.bat)”

This page says the next step is to run “Setup.bat”

I’ve tried it both ways now, with the same result, so maybe it does not matter… Suggestions?

Totally stuck here… I’m going to try to start from scratch with a new github pull.

Is there any way to verify these steps along the way?

Update: I started over from a completely new github pull, and followed the instructions again. I got an error, but it was not the error I was expecting. This led me towards a potential solution.

I was building inside VS previously in “development” configuration.

Once I switched to “development-editor” “win64” and built “ue4” my linux packaging works.