Packaging for Android doesn't work

I wanted to package a project for Android but everytime I try to do so, it seems as if it has worked, but when I look into the folder I set up, there is always only a version for WIN64 in it.

Am I doing something wrong, or is this a known bug?


I figured out how to solve it.

I had the android sdk installed manually. That gave me the ability to launch games on my device from the editor so I figured it worked. (did everything the wiki said)

Seems like it’s not enough though. I got rid of all these things and then installed the Nvidia Tegra Dev platform, which installs the Android SDK, Java and a few more things. Now I can package the game just fine.

If you wanna try it yourself, you can find the nvidia setup in your unreal engine folder:
Program Files\Unreal Engine\4.0\Engine\Extras\Android\tadp-2.0r8-windows.exe

I just installed tadp, launched UE4 and tried to package the project. Worked fine on the first try. Didn’t have to reinstall UE4 or anything.

So you need to install tadp and rebuild engine after that?

hi,do you have the file ue4game-armv7.apk in Binaries/Android? I have installed tadp ,but still not work.

Run GenerateProjectFiles.bat again and rebuild engine. Worked for me.