Packaging Failed (unknown cook failure)

I’m having problems packaging my project. For some reason it won’t package. I’ve tried packaging in development and shipping and always fails.

  • packaging for windows 64 bit
  • UE 4.10
  • blueprint project

I’ve read that the level may be too big as it says: MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: FMemoryWriter does not support data larger than 2GB. Archive name: E:/Work Folder/Unreal Projects/Shutter/Content/StarterContent/Maps/Minimal_Default.umap.

Some posts suggest level streaming and splitting up the level in areas. Would that work?

Also read that sometimes the lighmap might be too big. I’m setting the build quality to preview and trying again, see what happens. In the mean time i’m leaving a copy of my build log. If anyone can help me find the problem here, i’d be very grateful. I spent three months working on this and I really don’t wan to scrap it because UE refuses to build. There’s a lot of hard work involved in this :\


link text

Forgot to mention the game works fine in the editor.
I’ve also migrated only the maps i needed from the original project to a blank project and re-configured it to reduce size. It was also working fine in the editor. Tried compiling both the original project and the “clean” project and they both fail.

I managed to solve the problem. By splitting the level into three sections and level streaming each part accordingly seemed to solve the build problem. I also had an icon there that was corrupted. At least it builds, but now i have to deal with a number of bugs that never happened before i split the level.