Packaging failed - Black screen (DefaultMap)

Hi, so here I am again (Editor build from sources - Packaging does not yield game Binaries);
since I was told that the packaging problem was a known bug of the 4.0.x editor (see Why does packaging produce UE4Game.exe instead of gamename.exe?) I tried the “master” (4.1) branch.

But now, with a Blank project without any asset I do get a black screen only.
And with starter assets, I do get error during the cooking/packaging process.

Edit: I was wrong, see my answer above about DefaultMap

Development PC:

  • Windows 7 SP1 - 64bits - 8GB RAM
  • Intel Core2 Quad Q6600 @2.40GHz
  • workspace on the system 220GB SSD
  • Visual Studio Express 2013 for Windows Desktop - Version 12.0.30110.00 Update 1


  • GitHub source 4.0 branch - SHA 2092a941 by TimSweeney, 25/03/2014 15:47
  • +

Build Procedure:

  • GenerateProjectFiles.bat → UE4.sln → VS2013.1 - Development - Win64

Problem solved!
So basically, Packaging was successful, but it was not loading my map; the Saved/Logs showed it was launching the default Engine “Entry” Map.

Solution came from “Setting default map for standalone game”:

  • Edit > Project Settings > Maps
  • And select the preferred Game Default Map from the dropdown list.
  • Then use the Set as Default button

So thanks and sorry for the annoyance.