Packaging Failed (Automation Tool Unable to Run Successfully)

I’m trying to package my project for Windows, but the packaging fails every time. I’ve tried several different versions of the project with different conditions, but all fail. I’m basically at a loss, though it might be related to the “AutomationTool was unable to run successfully” error. Based the searches I’ve done, this seems to be an issue a lot of people have, but as far as I can tell there’s no clear solution.

I’ve attached my complete output log for my most recent package attempt, as well as specific error lines I found that might be relevant. If anyone can shed some light on what my issue is, I would greatly appreciate it.

I’m using Version 4.6.1 of the engine. I’ve tried multiple times to port my project to other versions, but have run into significant issues each time, so I’d like to finish with this version if at all possible.

Hey Chris,

In order to better assist you, I would like to ask the following questions:

  • Which version of the Editor are you using?

  • Did you receive the Editor from Binary (Epic Games Launcher) or Source (GitHub)

  • Are you only receiving packaging errors with this specific project?

  • Did you upgrade your project from a different version of the Editor?

    MainFrameActions: Packaging (Windows (32-bit)): UE4Editor-Cmd: [2015.08.24-20.21.22:245][ 0]LogInit:Display: LogCollisionProfile:Warning: Profile (UI) - Custom Channel Name = ‘Weapon’ hasn’t been found
    MainFrameActions: Packaging (Windows (32-bit)): UE4Editor-Cmd: [2015.08.24-20.21.22:245][ 0]LogInit:Display: LogSlate:Warning: Failed to load font data from ‘…/…/…/Engine/Content/Slate/Fonts/Roboto-Italic.ttf’
    MainFrameActions: Packaging (Windows (32-bit)): UE4Editor-Cmd: [2015.08.24-20.21.22:246][ 0]LogInit:Display: LogDirectoryWatcher:Warning: Failed to begin reading directory changes for C:/Users/Chris/Documents/Unreal Projects/Propulsion/Binaries/Win64. Error: 0
    MainFrameActions: Packaging (Windows (32-bit)): UE4Editor-Cmd: [2015.08.24-20.21.22:246][ 0]LogInit:Display: LogUObjectGlobals:Warning: Failed to find object ‘Object None.SM_SkySphere’

After reviewing your logs, I noticed that the editor is having trouble locating a ‘Custom Channel Name = Weapon’; has this been renamed, deleted or moved? You’ll need to look through your project to locate this file, or remove the reference where it’s being called from within your UI.

I would not worry about the ‘Roboto-Italic.ttf’ error unless it’s also causing your project not to package. If it happens to cause an issue for you, delete the binary, saved and intermediate folders from your project and then restart your computer.

Failed to begin reading directory changes for C:/Users/Chris/Documents/Unreal Projects/Propulsion/Binaries/Win64 was also caught by the packaging process. Did this file get moved, deleted or renamed? If so, could you please locate that file and ensure it’s in the correct location? You can also right-click in the Content Browser and ‘Fix up redirectors’.

The last error that was seen is that the editor failed to find object ‘Object None.SM_SkySphere’. Please verify that this object is still within your project, you may want to delete the object from your project viewport and replace it with a new version of the object. If the file was ever renamed, that could also be the issue that you’re running into, so replacing it within the viewport should fix that. I’d also check any blueprint that may be calling this object and check to make sure the names match up.

After you’ve done the following, please save your project and restart your computer, then try to package again. If you run into any further packaging errors, please upload the logs again and I will take a look at them.

Looking forward to hearing back from you, thanks!

Hi Samantha, thanks for your response. To answer your questions:

  • I’m actually not sure what you mean by version of the editor; I’m using version 4.6.1 of the engine.

  • I’m accessing it through the Epic Games Launcher. I have not used GitHub at all.

  • I ran a package on a basic third-person blueprint project as a test and I saw some of the same errors there- the “Custom Channel Name = Weapon” for sure, but it still packaged successfully. On the other hand, I copied all my necessary assets from this project into another basic template, and that failed as well.

  • I initially started the project in 4.4 and moved it through 4.5 to 4.6.1 over time. Moreover- and I can’t believe I forgot to mention this- I created this project on Mac and copied the files over to Windows. On Mac, it packages successfully but the packaged app runs very, very slowly.

Also, I noticed something while looking for the things you pointed out: none of my projects have Binaries folders. I created a new one just to check, and there was no Binaries listed. I’ve attached a screenshot of what C:/Users/Chris/Documents/Unreal Projects/Propulsion looks like. Any idea what the cause of that is?

Hey Chris,

Have you tried creating a copy of your project and moving it to 4.8.3? If so, were you able to package with that version of the engine?

So when you package for Mac with the same exact project, you run into no problems? When you say that you copied all your necessary files over, does that mean you’ve migrated your project? If not, go back into your project and try to migrate it to a new project and see if you run into the same issues.

You should not have any trouble based solely on the project being created on a Mac and moved to Windows. The projects are still compatible.

The binaries folder shows up once you package the game for instance, I’ve packaged this one project for Android, HTML5 and iOS.

56061-binaries+folder.png

Keep me updated, thanks!

Samantha,

When I previously tried copying the files to a new project, I just copied them over in the documents browser. This time I used the Migrate tool, and it worked! The project packaged successfully and seems to be working. If I run into anything else I need assistance with, I’ll create another question. Thank you so much for your help!

Posting this for the record, in case it may help someone else with a similar issue: I believe it was the custom .ICO image I was using for my game’s icon that was causing packaging to fail. My most recent version of the project packages fine with the default Unreal icon, but fails with the custom icon added and no other changes made.

Hey Chris,

You’re so very welcome! Please let us know if you have any further questions. The migration tool is specially made for the Editor and it’ll transfer your project over properly. :slight_smile:

Ok so I am using 4.9.2 and still getting the automation tool unable to run… Can not find this UE4.sln anywhere on my computer. I have Visual Studios Community 2013 and I access my stuff through the Epic Launcher. I only have 2 levels to package 1 is the front end and the second is the main level. How do i fix this???

Similar problem here and solved it migrating the entire proyect to a new empty one. thanks! :slight_smile: