Download

packaging error

Hi guys, not sure if this is the right place to put it in, but i will try :wink:
i have an error message packaging my game with 4.18.2. it happens very soon after i start packaging for win 64
here is the message:
UATHelper: Packaging (Windows (64-bit)): UE4-CustomLibraryPlugin.lib(Module.CustomLibraryPlugin.cpp.obj) : error LNK2001: Nicht aufgel�stes externes Symbol ““public: static class TSharedPtr<class FSlateApplication,0> FSlateApplication::CurrentApplication” (?CurrentApplication@FSlateApplication@@2V?$TSharedPtr@VFSlateApplication@@$0A@@@A)”.
UATHelper: Packaging (Windows (64-bit)): C:\UNREAL_PROJECTS\PROTOTYPE_026\Binaries\Win64\PROTOTYPE_026.exe : fatal error LNK1120: 1 nicht aufgel�ste Externe
UATHelper: Packaging (Windows (64-bit)): ERROR: UBT ERROR: Failed to produce item: C:\UNREAL_PROJECTS\PROTOTYPE_026\Binaries\Win64\PROTOTYPE_026.exe
UATHelper: Packaging (Windows (64-bit)): Total build time: 46,15 seconds (Local executor: 0,00 seconds)
UATHelper: Packaging (Windows (64-bit)): Took 46,3435839s to run UnrealBuildTool.exe, ExitCode=5
UATHelper: Packaging (Windows (64-bit)): ERROR: Command failed (Result:5): E:\UNREAL TORNAMENT\UE_4.18\Engine\Binaries\DotNET\UnrealBuildTool.exe PROTOTYPE_026 Win64 Development -Project=C:\UNREAL_PROJECTS\PROTOTYPE_026\PROTOTYPE_026.uproject C:\UNREAL_PROJECTS\PROTOTYPE_026\PROTOTYPE_026.uproject -NoUBTMakefiles -remoteini=“C:\UNREAL_PROJECTS\PROTOTYPE_02
6” -skipdeploy -noxge -NoHotReload -ignorejunk. See logfile for details: ‘UnrealBuildTool-2017.12.20-21.00.10.txt’
UATHelper: Packaging (Windows (64-bit)): (see C:\Users\user\AppData\Roaming\Unreal Engine\AutomationTool\Logs\E+UNREAL+TORNAMENT+UE_4.18\UAT_Log.txt for full exception trace)
UATHelper: Packaging (Windows (64-bit)): AutomationTool exiting with ExitCode=5 (5)
UATHelper: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults: Error: Unknown Error

can anybody help me with this ? I disabled any plugin, so i can be sure its not a plugin fault…
if not whom do i adress to with this kind of errors ?

kind regards
stucki

sorry to bother again,
but can anybody tell me please what is the right place i can send this problem to ?
i am not getting any further in getting my game to package (while i can play it totally fine in editor …)
is there some kind of official adress i can send my problem to ?
tried answer hub (no answer) and tried here already …
kind regards
stucki

Try to find out where is file “CustomLibraryPlugin.cpp” and why it can’t find what it’s trying to find.

thx for the answer ! if i search the project folder there is no “CustomLibraryPlugin.cpp” file. only a CustomLibraryPlugin.ini
so this isnt getting me any further sadly …
anyone else has any idea ?
and again, whats the right place to adress such an issue ?

kidn regards
stucki

hi guys, sorry for bothering… seems that i missed one plugin from disabling … stupid me :frowning:
thx for your time !!