Download

Packaging error , was working before - help

package fails for windows 64 bit almost right off. this is log.

Helper: Packaging (Windows (64-bit)): Running AutomationTool…
UATHelper: Packaging (Windows (64-bit)): Parsing command line: -ScriptsForProject=“D:/unreal projects/Shoot/Shoot.uproject” BuildCookRun -nocompile -nocompileeditor -installed -nop4 -project=“D:/unreal projects/Shoot/Shoot.uproject” -cook -stage -archive -archivedirectory=“D:/Cooked Unreal projects” -package -clientconfig=Shipping -ue4exe=UE4Editor-Cmd.exe -
clean -pak -prereqs -nodebuginfo -targetplatform=Win64 -build -CrashReporter -utf8output
UATHelper: Packaging (Windows (64-bit)): Setting up ProjectParams for D:\unreal projects\Shoot\Shoot.uproject
UATHelper: Packaging (Windows (64-bit)): ********** BUILD COMMAND STARTED **********
UATHelper: Packaging (Windows (64-bit)): Running: D:\UE_4.19\Engine\Binaries\DotNET\UnrealBuildTool.exe Shoot Win64 Shipping -Project=“D:\unreal projects\Shoot\Shoot.uproject” -clean “D:\unreal projects\Shoot\Shoot.uproject” -NoUBTMakefiles -remoteini=“D:\unreal projects\Shoot” -skipdeploy -nobuilduht -NoHotReload
UATHelper: Packaging (Windows (64-bit)): Took 2.7323476s to run UnrealBuildTool.exe, ExitCode=0
UATHelper: Packaging (Windows (64-bit)): Running: D:\UE_4.19\Engine\Binaries\DotNET\UnrealBuildTool.exe Shoot Win64 Shipping -Project=“D:\unreal projects\Shoot\Shoot.uproject” “D:\unreal projects\Shoot\Shoot.uproject” -NoUBTMakefiles -remoteini=“D:\unreal projects\Shoot” -skipdeploy -noxge -generatemanifest -NoHotReload -ignorejunk
UATHelper: Packaging (Windows (64-bit)): Took 3.2839301s to run UnrealBuildTool.exe, ExitCode=0
UATHelper: Packaging (Windows (64-bit)): Running: D:\UE_4.19\Engine\Binaries\DotNET\UnrealBuildTool.exe Shoot Win64 Shipping -Project=“D:\unreal projects\Shoot\Shoot.uproject” “D:\unreal projects\Shoot\Shoot.uproject” -NoUBTMakefiles -remoteini=“D:\unreal projects\Shoot” -skipdeploy -noxge -NoHotReload -ignorejunk
UATHelper: Packaging (Windows (64-bit)): Parsing headers for Shoot
UATHelper: Packaging (Windows (64-bit)): Running UnrealHeaderTool “D:\unreal projects\Shoot\Shoot.uproject” “D:\unreal projects\Shoot\Intermediate\Build\Win64\Shoot\Shipping\Shoot.uhtmanifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -Unattended -WarningsAsErrors -installed
UATHelper: Packaging (Windows (64-bit)): Reflection code generated for Shoot in 15.771843 seconds
UATHelper: Packaging (Windows (64-bit)): ERROR: System.NullReferenceException: Object reference not set to an instance of an object.
UATHelper: Packaging (Windows (64-bit)): at UnrealBuildTool.UEBuildTarget.GenerateLinkerFixupsContents(UEBuildBinary ExecutableBinary, CppCompileEnvironment CompileEnvironment, String HeaderFilename, String LinkerFixupsName, List1 PrivateDependencyModuleNames) UATHelper: Packaging (Windows (64-bit)): at UnrealBuildTool.UEBuildTarget.CreateLinkerFixupsCPPFile(CppCompileEnvironment GlobalCompileEnvironment) UATHelper: Packaging (Windows (64-bit)): at UnrealBuildTool.UEBuildTarget.Build(BuildConfiguration BuildConfiguration, CPPHeaders Headers, List1 OutputItems, List`1 UObjectModules, ISourceFileWorkingSet WorkingSet, ActionGraph ActionGraph, EHotReload HotReload)
UATHelper: Packaging (Windows (64-bit)): at UnrealBuildTool.UnrealBuildTool.RunUBT(BuildConfiguration BuildConfiguration, String] Arguments, FileReference ProjectFile, Boolean bCatchExceptions)
PackagingResults: Error: System.NullReferenceException: Object reference not set to an instance of an object.
UATHelper: Packaging (Windows (64-bit)): Took 25.9543113s to run UnrealBuildTool.exe, ExitCode=5
UATHelper: Packaging (Windows (64-bit)): ERROR: Command failed (Result:5): D:\UE_4.19\Engine\Binaries\DotNET\UnrealBuildTool.exe Shoot Win64 Shipping -Project=“D:\unreal projects\Shoot\Shoot.uproject” “D:\unreal projects\Shoot\Shoot.uproject” -NoUBTMakefiles -remoteini=“D:\unreal projects\Shoot” -skipdeploy -noxge -NoHotReload -ignorejunk. See logfile for
details: ‘UnrealBuildTool-2019.01.15-20.59.02.txt’
UATHelper: Packaging (Windows (64-bit)): (see C:\Users\raz\AppData\Roaming\Unreal Engine\AutomationTool\Logs\D+UE_4.19\UAT_Log.txt for full exception trace)
PackagingResults: Error: Command failed (Result:5): D:\UE_4.19\Engine\Binaries\DotNET\UnrealBuildTool.exe Shoot Win64 Shipping -Project=“D:\unreal projects\Shoot\Shoot.uproject” “D:\unreal projects\Shoot\Shoot.uproject” -NoUBTMakefiles -remoteini=“D:\unreal projects\Shoot” -skipdeploy -noxge -NoHotReload -ignorejunk. See logfile for details: ‘UnrealBuildTo
ol-2019.01.15-20.59.02.txt’
UATHelper: Packaging (Windows (64-bit)): AutomationTool exiting with ExitCode=5 (5)
UATHelper: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults: Error: Unknown Error

these are the error lines.

UATHelper: Packaging (Windows (64-bit)): ERROR: System.NullReferenceException: Object reference not set to an instance of an object.

PackagingResults: Error: Command failed (Result:5): D:\UE_4.19\Engine\Binaries\DotNET\UnrealBuildTool.exe Shoot Win64 Shipping -Project=“D:\unreal projects\Shoot\Shoot.uproject” “D:\unreal projects\Shoot\Shoot.uproject” -NoUBTMakefiles -remoteini=“D:\unreal projects\Shoot” -skipdeploy -noxge -NoHotReload -ignorejunk. See logfile for details: 'UnrealBuildTo
ol-2019.01.15-21.56.22.txt

UATHelper: Packaging (Windows (64-bit)): AutomationTool exiting with ExitCode=5 (5)

So , so far I discovered that if in project settings I select to encrypt any of the pak files for a shipping build , it causes these errors. if I unselect all the encryption checkboxes in project settings / crypto , then it gets past the error. Anyone know why this would be? Do i need to generate an encryption key before selecting to encrypt pak files? even for a windows build ? Thanks

Thank you ! Removing PAK encryption solved the problem