Packaging Error for iOS

Hello,
I searched for this particular issue throughout the answer hub, but was unable to find a solution. This is my first time trying to deploy a VR environment to my iPhone 6s. The project is just the FPS template as of now, and all I am trying to do is make sure everything is set up so I can launch it on my iPhone to test. However I keep getting an error when attempting this (see attached file).

I did have issue when installing Xcode. I downloaded Xcode 8-beta, which came in name “Xcode8-beta.app” but I was not able to get the launch process started. I then moved to the applications folder (it was not initially there) and then renamed the file Xcode.app. Now it begins compiling shaders and moving along, but fails at the same point each time. I am not sure if this has anything to do with the failure.

I am on a MacBook Pro running 10.11.6.

link text

Hi ryanXdesigns7,

Looking through your posted logs, the following error is present:

“ERROR: No modules found to build. All requested binaries were already part of the installed engine data.”

Searching the AnswerHub, the primary reason is a conflict with the Substance Plugin (disable this if active) or that you need to add a C++ element to your project if you are compiling your project in XCode. Add any C++ element, even if it’s empty and not being used, to correct this.

Let me know if neither of these resolves your issue.

-Steve H.

Steve,
Thanks for the suggestion! I completely forgot about this. I added a C++ element and it seems to be working just fine. I get a failed launch every now and then, but it appears to be working. Thanks!