Packaging doesn't continue

So no matter what platform I package a test project to, it just hangs. Please have a look at the log, I’m having this on every UE4 build and versions.

MainFrameActions: Packaging (Windows (64-bit)): Project.Cook: ********** COOK COMMAND STARTED **********
MainFrameActions: Packaging (Windows (64-bit)): CommandUtils.RunCommandlet: Running UE4Editor Cook for project D:\Windows.old.000\Users\user\Documents\Unreal Projects\surv 4.12\surv.uproject
MainFrameActions: Packaging (Windows (64-bit)): CommandUtils.RunCommandlet: Commandlet log file is C:\Program Files (x86)\Epic Games\4.12\Engine\Programs\AutomationTool\Saved\Cook-2016.05.08-15.21.33.txt
MainFrameActions: Packaging (Windows (64-bit)): CommandUtils.Run: Run: C:\Program Files (x86)\Epic Games\4.12\Engine\Binaries\Win64\UE4Editor-Cmd.exe “D:\Windows.old.000\Users\user\Documents\Unreal Projects\surv 4.12\surv.uproject” -run=Cook -TargetPlatform=WindowsNoEditor -fileopenlog -unversioned -abslog=“C:\Program Files (x86)\Epic Games\4.12\Engine\Pro
grams\AutomationTool\Saved\Cook-2016.05.08-15.21.33.txt” -stdout -FORCELOGFLUSH -CrashForUAT -unattended -UTF8Output
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd:
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: LogInit:Display: Running engine for game: surv
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: LogInit:Display: RandInit(1200836887) SRandInit(1200836890).
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.35:651][ 0]LogShaderCompilers:Display: Using Local Shader Compiler.
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.36:323][ 0]LogDerivedDataCache:Display: Max Cache Size: 512 MB
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.36:410][ 0]LogDerivedDataCache:Display: Loaded Boot cache: C:/Users/Hasan/AppData/Local/UnrealEngine/4.12/DerivedDataCache/Boot.ddc
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.36:427][ 0]LogDerivedDataCache:Display: Pak cache opened for reading …/…/…/Engine/DerivedDataCache/Compressed.ddp.
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:683][ 0]LogTemp:Display: Loaded TP AllDesktopTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:701][ 0]LogTemp:Display: Loaded TP WindowsClientTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:716][ 0]LogTemp:Display: Loaded TP WindowsNoEditorTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:735][ 0]LogTemp:Display: Loaded TP WindowsServerTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:752][ 0]LogTemp:Display: Loaded TP WindowsTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:769][ 0]LogTemp:Display: Loaded TP AndroidTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:784][ 0]LogTemp:Display: Loaded TP Android_ASTCTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:801][ 0]LogTemp:Display: Loaded TP Android_ATCTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:812][ 0]LogTemp:Display: Loaded TP Android_DXTTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:829][ 0]LogTemp:Display: Loaded TP Android_ETC1TargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:848][ 0]LogTemp:Display: Loaded TP Android_ETC2TargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:880][ 0]LogTemp:Display: Loaded TP Android_MultiTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:881][ 0]LogTemp:Display: Loaded TP Android_PVRTCTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:882][ 0]LogTemp:Display: Loaded TP HTML5TargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:913][ 0]LogTemp:Display: Loaded TP IOSTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:930][ 0]LogTemp:Display: Loaded TP TVOSTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:943][ 0]LogTemp:Display: Loaded TP LinuxNoEditorTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:962][ 0]LogTemp:Display: Loaded TP LinuxServerTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:980][ 0]LogTemp:Display: Loaded TP LinuxTargetPlatform
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.39:980][ 0]LogTargetPlatformManager:Display: Building Assets For WindowsNoEditor
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.41:618][ 0]LogCook:Display: Max memory allowance for cook 8192mb
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.41:619][ 0]LogCook:Display: Mobile HDR setting 1
MainFrameActions: Packaging (Windows (64-bit)): UE4Editor-Cmd: [2016.05.08-13.21.41:985][ 0]LogCook:Display: Done creating registry. It took 0.36s.

Hey BrokenSword,

  • Could you please upload the full error output logs as a .txt file with your next reply?
  • I’d also like to know what type of project you’re packaging and whether or not you run into the same issue when you’re trying to package one of our templates.
  • Are you running a binary or source version of the engine?

Thanks! :slight_smile:

link text

This is the first person template (BP), I use the binary engine build. It doesn’t proceed from there on. I kept the computer on for 24 hours but it won’t do anything from that point on.

The log that you provided seems to be incomplete. I need to have the whole log provided to me. Try to capture the whole log with your next reply, or simply upload your project so I can try and replicate the issue. If you don’t want your project to be available to the public, either change the privacy settings on your reply, or provide the link to me through the forums.

Thank you!

No that is the complete log. It hangs right where the text file ends. So that is confusing about it. I get this with all my projects even with templates. Also target platform is GearVR.

  • What version of the engine are you on?
  • Did you download it from GitHub or the Epic Games Launcher?
  • Have you gone through the following documentation: Samsung Gear VR Development
  • Have you tried just launching on?
  • What about using the Project Launcher instead of File > Package?

4.11 the most recent version, and tried 4.12 preview.

I’m running the engine from the Epic Games Launcher.

Yes I have, and the setup looks good.

I did try to launch it to the S7, however the launching only succeeds when launching it in ETC2 with Cook on the fly. This will allow me to see the app on the device with the message to attach the Gear VR, but as soon as I attach the device nothing will happen as it stays on a constant black screen as I believe that only the APK has been made without moving the game assets to the device. As soon as I choose the Cook by the book, the engine will hang and won’t give me an error, as it keeps on going without any actual progress.

I will try to build from source code via GitHub and will put the results here.

Did you get the OSIG file for the device?

Gear VR Prerequisites

Yes I have, I also tried to build from source but it seems like to be an hardware/software issue based on my OS. It doesn’t matter what project, target platform and engine version I use, the cooking of assets and deployment won’t work. So I’ll try to experiment a bit.

If you are able to obtain any longer logs, that would be super helpful to us. Looking forward to hearing back from you!

Nope still receiving the same logs. I’m trying it on another development PC. I’ll post results here.

Please post the logs when you can - thanks!

link text
This is the complete log, again it hangs right after Mobile HDR Setting. I’ve used the Third Person Template, and haven’t changed anything except the settings in the Project Settings to set it up for GearVR, and disabled Occulus Rift from the Plugins. Even if I package to Windows It still gives me the same results.

The error seen within your logs is as follows:

MainFrameActions: Packaging (Android (ETC2)): WindowsPlatform.get_Compiler: WARNING: Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that "Common Tools for Visual C++ 2015" was selected when installing Visual Studio 2015.
MainFrameActions: Packaging (Android (ETC2)): WindowsPlatform.get_Compiler: WARNING: Using Visual Studio 2013 toolchain instead of Visual Studio 2015 toolchain.

This means that there is a part of Visual Studio that you’re missing that is required for C++ projects. You can fix this by going to your Control Panel > Programs & Features > Microsoft Visual Studio 2015 and selecting “Change”. This should bring up the Visual Studio 2015 setup. If prompted for an update, you can hit Skip for now. After that, you should have the option for “Modify”. Select this and then find “Visual C++” under “Programming Languages”. Check this option and then hit next. Once it finishes, the correct module should be installed.

Please let me know if this does not resolve the issue you originally were having.

Thanks!

I allready did this right after I reviewed the log myself. link text

I think its best to leave it like this, As I believe that this is a hardware issue. I’m not sure how to ship the game to the store without the packaging as it prevents me and my team to ship the game.

It’s solved. The issue is due to the 2 cored Intel CPU. The CPU refuses to cook content, so that is the reason why it hangs. But Thanks for your help Samantha !