Packaging didn't worked correctly

Hey Samantha, I updated to 4.7.2 but still don’t get a ‘Saved’ folder after I packaged it and my game also won’t start.
I attached a .txt file I created. Pasted the Output log of the Editor in it.
Hope that there is a solution for my problem and thx again for your answer.
link text

Hey Samantha,

I’m using C++ and I want to package my project to give it some people to test it (maps, gameplay, respawn system etc.).In this package would be the player character, some weapon assets I wrote via c++ and bp, respawns, gamemodes, a map, bunch of assets used in this map including textures and materials. I tried to package it from the editor under File/Package Project/Windows/Windows (64-bit).

I followed your guide on this page: Packaging Unreal Engine Projects | Unreal Engine Documentation

Thanks. :slight_smile:

Hey Sentinel,

What are the exact steps you are taking to package your project? Please be as detailed as possible so I can follow the exact steps and reproduce this in-house.

I need to also know what you are packaging for and if you’re using a blueprint or a C++ project.

Are you using the packaging capabilities within the Editor or are you using UnrealFrontend?

Thanks! :slight_smile:

Hey Samantha,

I located that folder. Before the build starts it asks me where to save it and I saved it in a new folder on my desktop. After the build was successful I went to the folder. In this folder is a new folder called ‘WindowsNoEditor’. In it are following folders: Engine, [MyProjectName] and two files: [MyProjectName].exe and Manifest_NonUFSFiles. In Engine folder are: Binaries, Build, Extras. In [MyProjectName] folder are: Binaries and Content, but no Saved. If I try to run the [MyProjectName].exe it starts it in the background and close it immediately (checked it with the help of task manager). I tried to build it several times but still got this problem.

Hey Sentinel,

When you go to File > Package Project > Windows > Win64; where do you save the file to? That’s where your packaged project will go. It’ll be in a ‘WindowsNoEditor’ folder and a .exe will be inside. Have you been able to successfully locate that folder?

Hey Sentinel,

So you can locate your project.exe but it crashes on launch? Once it crashes, are there any logs placed in the saved folder? If not, please follow this link and obtain your logs for us, so we can investigate this issue further for you.

Thank you!
Samantha Sutton

Hey Samantha,

After the build completed it didn’t created a Saved folder. But I followed the link you gave me and found this file. Hope it’s gonna be useful. Was really confused that my packaged project doesn’t have a Saved folder.

Greetings Sentinel

link text

The Saved folder is in your ORIGINAL project. The one you package to has the directories all put back to normal. What exactly happens when you run the game in the packaged directory?

Hey Josh,

If I run the game nothing happens. I opened up task manager to see what exactly happens and I noticed that the game runs for about a second in the background and than it’s closed again.

Some recent information on this:

Sentinel has a lot of “Externally Referenced” Warnings. Together with the warning:

This map is using externally referenced packages which won’t be found when in a game and all references will be broken. Perform a map check for more details.

Would you like to continue?

It will break the game if he packages it. This is why his folder is so small and the game breaks on launch.

I guess he just needs to fix these errors.

Managed to fix these errors. They seem to occur when updating your Project to 4.7. The cached Data is the problem if the answers in other related questions are true.

Renaming the folder and restarting the editor seems to fix the errors. Let’s wait if the package works now.

Packaging said ‘Build successful’ but still can’t run the executable :confused:

Please add your latest logfile to your comment/question. So that the Staff guys can find the part that i’m missing.

All in all there are no errors in the log, only thousands of warnings about not found assets and “no version” assets that should be resaved.

Hey guys,

I’ve tried to build my project after 4.7.3 update and console says “Build successful” like always, but my game won’t launch. So I went to my “Logs” folder in my project and found those two logs but I don’t know what’s the matter why it won’t start my game. I really hope that someone has an answer for my problem because it’s frustrating right now not to build my game and test it with other people :confused:

link text

I’ve uploaded it to my OneDrive because I couldn’t upload the log file here (don’t no why it only said “No such upload”).

Hey Sentinel,

I have sent another request to our developers to review your logs. Hopefully I’ll receive word back soon. I just wanted to let you know that we haven’t lost your post, and we are working on it. :slight_smile:

Thanks!

Two things to try:

1 - We still don’t have a runtime log, so it’s basically impossible to tell what is happening. Go to a cmd prompt, cd to the packaged project’s Binaries\Win64 directory, and run the .exe with -log. Maybe that will tell us something useful.

2 - Try packaging for Win32, not Win64, and see if the results are any different.

Josh

Hey Josh,

I gonna try it now give me some minutes.

Hey Josh,

I tried both of your solutions but nothing really worked.

    • In cmd after I typed it in with the ‘-log’ it executed the Game in the background for a second and closed it immediately, in cmd itself it just went one line down and showed the current path I’m in noting more.
    • I packaged my project for win32. After the packaged was done it said ‘Build successful’ like always but if I wanna start my game it starts it in background for a second and close it immediately.
      link text
      I uploaded the log file again of the win32 build on my onedrive because I couldn’t upload it here :confused:

Really hope there is a solution for this and thanks that you guys try to help me with this problem.

Greetings Sentinel

Again, that’s just the packaging log, it is not the runtime log. It’s not helpful for debugging.

In your packaged project, do you see MyProject/Saved/Logs directory with logs in there?

Josh

There is no Saved/Logs folder in my packaged project.

Greetings Sentinel