Packaging build for gear vr results in empty folders

So I have gone through various tutorials for gear VR implementation and, as there are many steps and installations, something still seems to be going wrong. I am using a Galaxy note 5 with the consumer version of the Gear. We have our settings mirroring the steps from the UE guide but for some reason when I try to package the build it takes a good 20 minutes, to be expected, then creates an Android_ETC2 folder in the one I specified yet that folder is empty. The only thing I can think is questionable is the Tegra/Codeworks sdk. So as the note 5 is new and documentation on proper installation has been scarce and I wonder if it’s the same process as the note 4, which has great documentation. Are we supposed to use Tegra or Codeworks, and do they need to be installed on the C drive for any reason, because mine is very low on space. I’m just trying to trouble shoot anything because I keep getting stumped along the way. Is there a definitive guide on how to put a UE4 project on the Note 5 for the gear?

Hi FlickNolis,

No, if you are packaging instead of launch on, the device doesn’t matter to the cook/package process. If you aren’t seeing an APK in the Android_ETC2 folder at the end then the packaging failed somewhere. You will need to look at the output log to see what went wrong. You should be using the AndroidWorks 1R1 from the extras folder, but if you have the right APIs installed (API 19 is the critical one) you should be ok. Just make sure if you installed API 23 that you have your Android SDK project settings set to “matchndk” instead of “latest” in Android SDK project settings.

Still getting an empty folder when packaging project for GearVR

First, thanks for your help! It still doesn’t seem to be working. We installed AndroidWorks 1R1 from the extras folder and everything is set to what it should be via the UE instructions. . The only yellow warning I get in the output log is “LogUObjectGlobals:Warning: Failed to find object ‘Class None.’
LogLoad: Full Startup: 16.60 seconds (BP compile: 0.00 seconds)
LogOcInput:Warning: OculusInput plugin enabled, but OculusRift plugin is not available.”. Would Android works have any reason to be installed on the C? I have limited space on my C so its installed on my D drive. Any help along the way would be greatly appreciated! I’m attaching my output log, if you see any red flags please let me know and thanks again!

while i’ve never encountered this issue in particular (so not sure if its saying this but may actually be another issue)

It seems like your project is on the D drive, and is packaging to the C drive, did you check to make sure there was enough space?

Can you check to see if some of it was partially packaged in your project directory

Still failing packing process for Gear

Ah yeah it was putting it on my C drive and there is not enough space there. So that was fixed but now it’s failing to package a build at all. It says something about “LogUObjectGlobals:Warning: Failed to find object ‘Class None.’”. I’ll add the latest output log so you can take a look, and thanks for getting back to me so quickly!

Well one problem down!

Class None error i believe is from deleting a class/bp but it is still in level/referenced somewhere (usually doesn’t happen), but I don’t think it will make it fail outright.

Just a general/random tip , make a backup of your project, try deleting (or moving it out of your project folder) the intermediate, saved, and build folders. This may make you lose some project/build settings, but forces a clean packaging.

Hi KRushin,

Based on the log it seems you turned on “Build Http Chunk Install Data” checkbox without setting the data directory and data version in the Packaging section on Project Settings. Turn off this checkbox and see if it works.

So we’re now trying to see if there is a root issue with any part of the process so we created a new project, 1st person with default everything minus the Vr settings that we followed from the UE tutorials. So now we can get a build of the game to the phone, the default 1st person template, however when we go to the application manager, gearVr service, then manage storage, then we clicked the vr service version 6 times and that enabled VR developer mode, we launch the app from the phone home screen, we boot up the build and it loads but it doesn’t go into split screen vr mode and it has the android default thumbstick control UI. It works but it doesn’t seem to be going into VR. Progress for sure but I feel like there has to be something simple thats unchecked if we got far enough to get a build of any kind running on the phone. Does it matter that we are using an unlocked Note 5 without a carrier? I’ll include the Output log and thanks again, you guys are life savers.

Hi FlickNolis,

You need to turn on the Package for GearVR checkbox to get the splitscreen.