Download

Packaging: Best way to bypass UnSetup.exe's registry checks?

Can anyone who has successfully packaged their UDK game onto Steam tell me how they bypassed or fixed UnSetup.exe’s registry checks. It performs a registry check for the EULA and crashes when the game is launched on other PCs since it wasn’t installed using an UDK installer. I am using Feb 2014 version of UDK.

Also for dependencies UE3Redist.exe launches a big UI which I don’t think can be hidden anyway. From what I see it’s VC++ 2010 and DirectX 9.0c which are available in Steam itself. Are there any other dependencies that i should know of? Will Steam’s own Redist’s work fine?

The way I do it (may not bee the best way but this is my 2nd steam game using this process …) is I install the game on my PC then I have steam via the build app do a compare for files and it uploads and creates a depot in steam.

You then can let steam download and install the game into the steam folder for the player.

I let steam handle the whole process. If I want a new update into steam I uninstall the game from my pc reinstall into the same folder, run the app build process again which compares changed files with whats in steam and it uploads a new depot which the player can download once you authorise it. I replace the EULA with a copy of mine instead of the UDK EULA as its the game not UDK that gets installed.

Which version of UDK are you using? This problem was introduced after 2013 something version. You might be using the older builds so you are not getting the problem.

July 2012, wasn’t aware there’s an issue with later versions, if you install the way I do through steam I wouldn’t expect you to get an issue, you don’t use the udk setups or package.

It’s a confirmed issue:

There is a memory leak in your build btw:

Thanks for the info, yeah just tried and it took a while but the leak did occur. Something else for me to consider …

You could at-least tell me about the dependencies though.

In the steamworks page see the installation tab and under there you can select the redistributables and have steam install them

Yeah i know that but which ones are required?

I’m using the 2014 UDK release, and i haven’t encountered this issue.

TBH, I’ve never asked that question, I ticked the Direct x and 2010 dist based on what I thought UDK was installing.

Are you testing on your own PC? Then the issue won’t pop up because the registry keys are activated on your PC. You should make a copy of the game files and uninstall the game installation and then try launching the .exe from the copy.

My current game has been installed on other peoples pc’s after they downloaded and installed from steam. I also used the same method to release another game on steam prior to my current game.

You have the older UDK version when it worked without problem.

So did anyone manage to find a solution to this? My game is asking players to agree to the terms each time i push new updates.

Did you give them the installer made from Unreal Frontend or the game files directly?

@chimera201 It’s the game files directly i’m uploading to steam. Everytime I push an update, it forces all player to agree to the EULA again, and it registers a new app in every players programs list:

It’s pretty annoying and several players have complained about it.

Anyone know how I can fix this?

Which UDK version are you using? I don’t know how that’s possible if you directly giving them the game files. Maybe something changed in a later UDK version? Did they screw it up more?

There are like 3 ways of going about my original problem.

  1. Use Unsetup.exe of an older UDK version when it didn’t have the registry check
  2. Create a blank exe manually and use it as UnSetup.exe
  3. Manually edit the registry keys through a script.

I think i’m going to use the blank exe approach whenever my time comes to ship. I hope it doesn’t violate any Epic’s rights.

How did you package your game in 122MB ? :confused: