Packaging android game error

link text

UE Version: 4.9
First I could package my game but I got a error of “no obb key and no google play store key”. So I tried to fix this problem. But now I can’t package my game anymore. In conclusion I think it’s probably due to the creation of a google play store key and/or the adding of the SDKConfig in Android SDK.

Alabastine6,

Please try a newer version of the engine and see whether or not you’re able to package a newly created template project for Android. Also, double check to make sure that in C:\NVPACK\android-sdk-windows that the SDK Manager has ‘All Tools’ downloaded and installed too.

Let me know how it goes, thanks!

I tried to package a new project (version: 11.2), It resulted in the same error. Next I reinstalled codeworksforandroid because the version located in engine/extras was 1R1. In the android quick start guide (from ue4 documentation) there is a message: “If you have other versions of the Android SDK installed, it is highly recommend that you uninstall them and then re-install CodeWorks for Android using the CodeWorks for Android 1R4 installer that is bundled with UE4”. So I downloaded and installled 1R4. But I got some problems during installation which forced me to reinstall visual studio. In the end it all works (I think). But I have got the same error while packaging the game. Also I checked if all tools were installed. I don’t know if this is all the tools but the tools I see: build tools and platform tools.

Install 1R4u2 since you’re on 4.11.2. Make sure that once you’ve done that, you’ve installed the proper versions of the Android SDKs and added them correctly to the engine.

  1. The game is on version 4.9
  2. I can’t find version 1R4U2 download on the internet
  3. I’m pretty sure I found the problem: “Compile Samples Failed” (in installation of 1R4U1). Error message: “The license for visual studio has expired”. I thought that I already solved this problem by deleting visual studio 2015 and installing visual studio 2013 but it seems that it didn’t work.

Update: I reinstalled 1R4U1 correctly and I reinstalled android studio. Still it doesn’t work.

[link text][2]

Update 2: I installed all tools in SDK manager in C:\NVPACK\android-sdk-windows. (First I thought I did this but it didn’t understand it but after some research I knew where to look and managed to install the tools. Still it doesn’t work :frowning:
link text

It looks like you’re on the wrong version of Java, please update it and try to package again. Let me know if that resolves your error.

I tried it (java is now up to date) but it stil doesn’t work. After some research on the web, I opened cmd an typed ant debug . Result: Buildfile: build.xml does not exist! Build Failed. I don’t know if this means anything but I still wanted to share it because the more information I share how faster this problem can be fixed (I think/hope)

Make sure your settings are set up like this:

  • Go to Edit > Project Settings > Android SDK
  • Set Location of Android SDK to C:\android-sdk-windows
  • Set Location of Android NDK to C:\android-ndk-rXX, mirroring the folder name in the version you’re using.
  • Set Location of ANT to C:\apache-ant-1.8.2
  • Set Location of JAVA to C:\jdkXXXXXXX, mirroring the folder name in the version you’re using. (mine is on 1.8.2)
  • matchndk
  • android-19

It works! First I moved SDK,NDK and ANT file to C:. After that I installed from 1R5 the jdk 1.8 (prev version 1.7) moved this to C: and adjusted the project settings. Thanks!!