Packaging always fails after installing Visual Studio?

So I just finished another project in Unreal, but something different happened this time when I tried to package it for Windows 10 64-bit usage. It said that I did not have Microsoft Visual Studio installed. This had never happened to me before. I went ahead and installed Visual Studio and restarted Unreal. After clicking to begin packaging again, the project begins to package for about five seconds, and then says “Packaging Failed.” Any reason why Unreal is suddenly freaking out like this? I’ve never had issues before (and I’ve never needed Visual Studio before either).

I’m not sure what could be causing this, but a few quick questions whilst I do a bit of searching.

Firstly, just to clarify - your project is a Blueprint only project, correct?

Secondly, are you certain that your project settings (namely the Edit>ProjectSettings>Packaging page) are setup correctly, because this could certainly cause packaging issues.

Finally, does the Message Log offer any useful insight into the problem? If so, we could do with knowing it!

Good luck!

Edit: Just an after thought - have you tried a new, blank project, or one that you used to be able to package? That may narrow down whether it is this project or a wider problem with the engine.

Had enough of my questions yet? (last question - honest! ^^’ )

This just looks like you forgot to mark a checkbox in Visual Studio (installing Windows SDK and probably 32bit toolchain). Can you try following this answer and report back?

What do you mean my blueprint only project? And I believe my packaging settings are set up correctly. I haven’t changed anythingi n there ever…And I’ll paste what the message log says in red to try and give some info as to what might be causing it.

UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: Windows SDK v8.1 must be installed in order to build this target.

UATHelper: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.CommandUtils+CommandFailedException: Command failed (Result:5): C:\Program Files\Epic Games\UE_4.17\Engine\Binaries\DotNET\UnrealBuildTool.exe SciFiWorld Win64 Development -Project=“C:\Users\Ethan\Documents\Unreal Projects\SciFiWorld 4.17\Sc
iFiWorld.uproject” “C:\Users\Ethan\Documents\Unreal Projects\SciFiWorld 4.17\SciFiWorld.uproject” -NoUBTMakefiles -remoteini=“C:\Users\Ethan\Documents\Unreal Projects\SciFiWorld 4.17” -skipdeploy -noxge -NoHotReload -ignorejunk. See logfile for details: ‘UnrealBuildTool-2017.10.23-11.25.14.txt’

PackagingResults: Error: Unknown Error

LogTemp: IPP ERROR: Could not find provision directory ‘C:\Users\Ethan\AppData\Local/Apple Computer/MobileDevice/Provisioning Profiles/’.

I also tried installing 4.17.2, moving the project into that one, and packaging it there, but that did not work either.

And for the last question, I can package the project I packaged in the past. It’s only this new one, so I believe it’s a problem with the project.

Sorry, I meant is your project set up as a blueprint project or a C++ project.

Take a look at this answer:

Just going off that first error message from the Unreal Build Tool, it would seem that you’re missing the software development kit. The link above suggests downloading it.

As Ninjin says - you probably missed a prompt during installation that would have installed this for you.

This worked perfectly! Thank you!

I get Visual Studio errors out of the blue as well… I never installed it. And my project is entirely BP. And all worked until now. I didn’t make any major changes… just a bit of BP stuff…