Packaging a project in GNU/Linux - Fedora 23 - Error

Hi all,

First of all to tell you that I’ve searched a lot on this AnwserHub and I didn’t find the solution for my case.

I currently have Fedora 23 64 bits GNU/Linux and I’ve Unreal Engine 4.8.3 compiled from Fedora 22 (my previous version of the OS) with clang 3.5.0, following steps from several pages from this site.
On Fedora 22 I didn’t have any issues when compiling, after following all steps and solving some dependencies.

Then when I moved from Fedora 22 to Fedora 23, I saved a copy of the Unreal Engine folder and copied into the new system, as I performed a Fresh Install.
As I have it compiled already, there’s no issue opening the Editor and creating the games, compiling blueprints nor executing them.

My issue occurs when I try to package the project for Linux following the next steps:

  • File > Package Project > Linux
    After saving a Location, immediately the following error message raises:
    “Packaging Failed! Show Output Log”.
    Checking the log, the error found that repeats constantly is the following: “MainFrameActions: Packaging (Linux): RunUAT ERROR: AutomationTool was unable to run successfully.”

The ideal situation would be to be able to compile for GNU/Linux on the current OS I have.
As I have Windows 7 on dual boot, I copied the project folder there and I had no issues packaging it for Windows.

I’ve read that I could use cross-compiling from Windows for GNU/Linux, but first in order to enable this I should compile the Source Code on Windows, performing the additional steps to include the GNU/Linux cross-compilation, which I preferred to not perform and didn’t have enough time at the moment.

I think that the issue might be due to not having Fedora 23 with the mono libraries from their own repositories.
I have downloaded clang 3.5.0 version in binary from form their website and exported the path onto the $PATH variable, so when I check the version it is installed.

I thought that once the Unreal Editor is Fully Compiled there shouldn’t be any issues in the packaging, but it seems I was wrong.

I’m attaching here the Output Log from Today’s try.
link text

Thanks a lot to all for your support.

Best regards.

Hey Oriolr4-

Looking at the output log, it appears to be looking for a folder UnrealEngine/Engine/Plugins/Experimental/CharacterAI/Content/ which it is unable to find. Do you have any assets in your game that are referencing this folder? Additionally, can you let me know if you are able to create and compile a new blank project, or do you get the same error?

Hi Doug,

In regard to the first question, it seems this error raises when Unreal Engine is starting, before selecting the project to open, I’ve attached screenshot labeled ‘UE4_Fedora23_StartingUp.png’.

The same error is also appearing again in the terminal when creating a new project or opening an existing one.

For the second one, I tried to create and compile a new blank project and no issues appeared.
I then proceed to package it for Linux, and it started packaging.

After 2 hours it is still cooking/packaging the scene with the 2 chairs and the table.

Thanks for your fast reply and support.

I’m not seeing this error when starting the engine. Can you let me know if you have the same problem with a more recent version of the engine (4.11.2 is the latest release version available).

Hi Doug,

Sorry for the late response.
I had a lot of work and could not reply earlier.
Then I found that my Fedora 23 OS crashed and could not recover.
I proceeded to format the partition and reinstall the previous version - Fedora 22 -, the one that I used some time ago to compile the Unreal Engine version 4.8.3 that later I used on Fedora 23 until now.

At the moment I’m following the same steps I used the last time, found here:
https://forums.unrealengine.com/authorize.php?code=dd2ee96b3dcc478da3e93252b09c4847&state=https%3A%2F%2Fforums.unrealengine.com%2Fshowthread.php%3F53451-Successful-4-6-0-build-on-Fedora-20-x86_64
It is for Fedora 20 and version 4.7, but it worked fine for me in Fedora 22, adding some additional steps for missing libraries.

Once the building completes, I’ll try again to Package the project in Linux, and also I’ll try it with the newest version you indicated - 4.11.2.

I’ll update here the results as soon I have them.

Thanks a lot for your support provided.

Hi Doug,

Just to tell you that I compiled Successfully Unreal Engine 11.0 (Last version from GIT for GNU/Linux) on Fedora 22.
The error provided for version 4.8.3 is not present here (the error raising when starting the UE4 Editor).
I tried this time to package for Linux my project and it run fine.
It took 2 hours and 30 minutes more or less, it is quite time, as in Windows it compiles in 1 minute or less for version 4.8.3, but no problem, I’m sure this is being improved on each new version, and support for GNU/Linux is better as well.

So, I did not try again with version 4.8.3 on Fedora 22.

Only one last question, If any time I move again to Fedora 23, if I copy the folder with the generated folder for downloaded and compiled Unreal Engine 11from Fedora 22, will I be able to package the projects for Linux on the new OS?

Thanks a lot again for your support.

Best regards.

Hi again Doug,

Just to add, that the second time I packaged the project, although I marked the Full rebuild on packaging settings, it took half an hour and the executable file is working as expected :slight_smile:

I missed to include this comment on the previous one.

Hey Oriolr4-

Copying the built engine to your updated OS should be possible. If you do encounter issues after updating the OS, feel free create a new post with as much information about the issue as possible.

Hi Oriolr4,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Hi Doug,

Sorry for my late response.
I compiled version 11.0 on Fedora 22 and I was able to package the project as well.
Thanks a lot for your support, much appreciated.
I’ll try to do the same with the newest version at the moment - 4.12.5 - which I successfully compiled on Fedora 22 (also I have it installed on my Windows 7 OS).

Sure this can be closed.
Thanks again for your support.

Best regards,

Oriol Rossich