Download

Packaged/Standalone level change bug (Will effect anyone trying to package their game.)

How to reproduce:

  1. Have two simple levels. Literally does not matter what is contained in the level.
  2. Have the first level navigate to the second level at any point with “Open Level”.
  3. Open game in Standalone window. Or package your game and open it.
  4. You should see the screen become huge and unusable. The screen no longer fits inside your game window.

Expected:
Step 4 should not result in oversized screen that becomes unresponsive.

I was able to reproduce this in a minimal project. Seems like a project breaking bug.
UE4 version: 4.25.2

Example ScreenShots:
First Level:


BP used to change to Second Level

Second Level (Just a copy of First Level with BP code removed.)

This will impact anyone who attempts to package a game that uses at least 1 level change.

Bump. This is preventing me from packaging my finished game and distributing it.

Bump, this does not occur in version 4.24
However, it’s not possible to downgrade as UE4 does not support backwards compatibility. So I’m still stuck.

I tried verifying my UE4 but the problem was still there. I tried downloading UE4 on a completely different computer and the issue was not present at all. I’m super confused now. Do I need a complete re install of UE4???

Likely, your problem is that the character is already plunging into nothingness along with the camera by the time you load level.
You should really set the pawn movement type to nothing, then once the load is complete / or after a 1 sec delay re-enabe movement.

This is not the problem at all. I see this problem even in a fresh install of this persons product:
https://www.unrealengine.com/marketp…validated=true

However, I tried running his project on my downstairs computer and I do not see the problem. I have attempted to completely uninstall UE4 from my upstairs computer and the problem is still present in both the project listed above and a minimal project. Something is wrong here and I’m not sure what it is.

This is what I see on that linked project… see how the screen is way too big? Doesn’t fit in the window?

](filedata/fetch?id=1792787&d=1595687542)

Here is what it is supposed to look like:

](filedata/fetch?id=1792788&d=1595687637)

Please tell me again how this is my fault

I’ve pulled my main project down onto my downstairs computer using Git. I was able to run my project down there and the issue was not present. Considering I tried a completely fresh install of UE4 and deleted my saved and intermediate folders on this upstairs computer there’s something going on that I will not be able to track down. Something wrong with my computer? But it only happens in standalone mode.

Regardless, I have a way to publish my project now. If I could go back to the beginning with all the knowledge of UE4 that I have now, I would have known NOT to use it to build games. Holy ****.

Incidentally. Git is a pain to use with UE4. I had to write a script that chunked the larger files into smaller pieces so that Git would not reject them when pushed.

For anyone else that ever has this problem I’ve found the solution. The issue is that the Oculus and Steam VR plugins were enabled by default. Oculus was attempting to open the game. So if you have the Oculus software installed you will see this issue with a fresh project. Unless it’s your intention to make a VR game, then it’s not a bug at all.

The fix is to simply disable those two plugins.