Packaged Project shows 'Not Responding' but works fine

TLDR; Game works fine in editor, works also fine after packaging, but shows sometimes “Not Responding” for a couple of seconds in Task Manager while “inactive”.

Is there a way to fix this or is this even a problem?

I build a first person game with UE 5.1.1 for Windows and everything seems to work fine. But if I run Task Manager while playing the packaged game I get “Not Responding” next to the application name inside task manager in a weird pattern:

  • If I am running around or moving the mouse: task manager shows nothing
  • If I am still in the game but don’t move or don’t make any inputs: I get a “not responding” message sometimes for a couple of seconds inside Task Manger. Animations and Blueprints inside my game keep working without an issue (for example waves or a ceiling fan) and there is also no rise or drop of CPU usage or framerate.
  • If I click outside my game but leave it running in the background: I get the “not responding” message more frequently and for longer periods at a time. Animations and Blueprints inside my game keep working without an issue.

I created a completely new project from the Epic Game Launcher, packaged it without any adjustments and I still get the exact same issue.

My general questions would be:

  • What could be causing this?
  • Is this even a problem (since everything seems to be working just fine)