Packaged project plays timeline differently on different machines


I’ve got two issues … which might be related…

  1. The timelines I’ve set up work perfectly when I play in editor, but when I package the project they change.

I’ve managed to get them to be the same by deleting the content from the Project\Saved\StagedBuilds and then building … this works on my windows 8.1 machine. But not on the windows 7 machine. And might just have been a coincidence.

  1. Strangely, the packaged projects work fine on the windows 8.1 machine no matter if they were packaged on the windows 8.1 or 7 machine. But they run slow on the windows 7 machine … also independent on which machine they were created on.

The project sizes are quite large … over 20gig with the packaged project in the Staged Build folder. Could that be having an effect?

Any help much appreciated!


Update … I’ve found that if I change the Engine Scalability Settings (under Settings in the top toolbar) I can make the timelines play at different rates in “Play in Editor mode”. At low and medium settings the timelines play as they should … at high and epic settings the timelines get cut short. Unfortunately this doesn’t carry through to the packaged project. Does this make any sense?

Update! … I followed this advice to get the Engine Scalability Settings into the stand alone (packaged0 game: Scalability Reference does not apply to standalone Game - Platform & Builds - Epic Developer Community Forums and it worked! Now all I need to do is figure out what the settings should be for “medium” and I’m good to go.