Packaged Project Crashing when Opening Map

Hello,

I’m having an issue with my packaged game crashing when trying to open the first level of the game. My main menu opens fine and I can access the entire interface, however when I try to start a new game, it crashes and just says:

"You do not have any debugging symbols required to display the callstack for this crash."

When I launch the game and attempt to start a new game this is the only error it shows:

LogUObjectGlobals:Warning: Failed to find object 'Class None.'

But nothing seems to throw an error or warning during packaging. I’ve included my logfile for the last time I tried to package the project.

It’s also worth noting that everything works perfectly when trying to play the game in the editor, even when launching as a standalone game.

Things I’ve tried:

  1. Checking the cook entire content folder box in packaging options.
  2. Deleting the Saved, Binaries, Intermediate and Build folders
  3. Cloning the project and cutting out all of the assets that I know are not used in case there were any errors coming from them.

I’m at a loss here as I’m not encountering any problems until trying to play the packaged game. Any help would be greatly appreciated.

Log File

##Edit:

I’ve looked through the log file and it appears that it’s trying to load assets that it shouldn’t, specifically these files:

Can’t find file ‘/Game/Realistic_Weapons_Pack/Meshes/St_Tracer_A’
Can’t find file ‘/Game/SciFi_Weapons/Meshes/St_AssualtRifle_Core_01’
Can’t find file ‘/Game/SciFiWeapDark/Weapons/Darkness_AssaultRifle’
Can’t find file ‘/Game/SciFiWeapDark/Weapons/Darkness_Pistol’
Can’t find file ‘/Game/SciFiWeapDark/Weapons/Darkness_Shotgun’
Can’t find file ‘/Game/SciFiWeapDark/Weapons/Darkness_SniperRifle’

I guess it’s an issue from the asset set that I bought from the store. I had moved the weapons to a different folder previously but I made sure to fix redirectors in pretty much every folder before packaging. Also, the first two files there never actually existed in the first place and must be references left over from the original author of the assets. Is there anything I can do about this?

Hello KaseZer0,

I have a couple of questions to help narrow down the issue you are experiencing.

  1. Does this same issue occur if you package a new project with the Sci-fi weapons pack and try opening a level with one of the assets in it?
  2. Do you have the event driven loader enabled?
  3. What platform are you packaging for?

Thanks!

Hi Thomas,

Thanks for the reply. I apologize for the wall of text that follows:

To answer your questions:

  1. I used the default first person example project and dropped in the SciFi Weapons. It packaged and worked fine.
  2. The event driven loader is enabled.
  3. I’m packaging for Windows 64-bit.

I think it’s also worth noting that I’m not using any 3rd party plugins.

Log Files:

I’ve attached the log for the test project. I addressed a few warnings I noticed in the original log file and re-packaged the project.

  • [First Person Example Project Test][1]
  • [Re-package Log][2]

Crash Report:

Finally, I’ve attached a crash report for the packaged game that I sent the logs for to see if there’s any info you can get from it. It’s also odd that it won’t show me the error because I have the debug symbols installed on my computer.

Edit:

I read on another post that disabling the event driven loader can help, so I disabled it in the project settings. It reduced the number of warnings/errors significantly but there’s still a few remaining. The project also still crashes.

I’ve attached both a log file and error report that was sent in for the project with the Event Driven Loader Disabled:

[No Event Driven Loader Log][4]

Update:

I’m not sure of what was wrong with my Level1 map, but it was giving me issues in the editor after the builds, so I remade the map. I can now package and run the game with only one (major) issue: my projectiles don’t collide.

Oddly enough, it only happens in the built game. The projectiles work fine in the engine. When packaging is there any specific flags I need to give to include custom traces that I’m missing?

I still get the warnings for the few assets that it says don’t exist (but they never existed in the first place).

I’m guessing either the custom trace I’m using for the projectile collisions or those meshes need to exist for the collision to work. However the meshes never existed in the first place, at least on my machine.

Working Package Log

Solution:

The solution to fix the crash when starting the level was to disable the “Event Driven Loader” setting in the project settings.