Packaged project crashing on startup 4.22 after adding a c++ class to project


I have been having an unusual issue where my packaged game is crashing immediately upon startup with a fatal error message, but it will restart and run normally from that point onwards, even on repeat plays.

The logs aren’t showing anything that seems obvious, and the project did not have any errors or warnings whilst packaging. I’ve looked online at all other possible solutions and I can’t find anything, I have tried this on a new project and I don’t get the issue, but I have tried a new map in the existing project with a standard third person pawn and I still get the crash. I don’t really know what else it could be inside my project. :S

Any possible suggestions with what this could be would be super helpful, I’m running out of options.

[Packaged game log][2]

I’ve managed to narrow the problem down to a specific area. It turns out that I get this whenever I add a C++ class to a project. I have managed to replicate this issue on a blank project in 4.22. I was specifically adding a Blueprint Function Library class.

Anybody know what this could be?

I have same problem