Packaged games does not start on integrated Intel Graphics Cards

Packaged Game Crashes to desktop on Intel Integrated Graphics Card


I’ve been having an issue where my for my packaged game (blueprint project) is crashing to desktop without any errors/crash logs.

Issue Outline

  • Issue only seems to happen to integrated Intel graphics cards
  • its been experienced by a handful of people running the latest build of my game and they are all on integrated Intel GPU cards.
  • This issue seems to have appeared after I migrated my project to unreal engine 4.21.2
  • This crash does not occur for my last build which uses the previous Unreal Engine Version 4.20.3
  • This crash does not create any crash logs

Step taken to resolve the issue

  • I have no packaging errors in my game but I’ve tried resolved as much of the packaging warning (yellow) as I can.
  • Strangely, I’ve packaged a template game (flying game) in unreal (4.21.2) and that crashed in the same manner.
  • The same template game (flying game) created using 4.20.3 works so it seems to be limited to the latest version of UE
  • I thought this issue could be related to visual studio so I’ve tried to:
    • reinstalling visual studio 2017
    • compile using Visual Studio 2015 and has the same issue.
  • Reinstalled unreal engine.
  • Delete intermediate/binary/save folder in project folder.

Test Laptop Specs:
CPU: Intel i5 - 3337U
Memory: Memory : 4GB
Video Card: Intel HD Graphics 4000

I would greatly appreciate any assistance to help me resolve this issue.

Has been happening to me too on packaged builds after an upgrade to 4.21.2 on Intel-only integrated graphics

Glad to hear that I’m not the only one who is experiencing this.