Packaged Game wont work

I have a main menu for my game and when I click start in the testing window it works but in the packaged game it just reloads the menu level can anyone help me?


I have attempted to reproduce your issue, but I was not able to do so. My Open Level continued to work when I clicked on my button in a packaged game.

  • What platform are you packaging your game for?
  • Do your other button events work?
  • Also, just to be clear, you said this same setup works when you test it in the editor?

The other buttons work. I am making the game for PC. Yes, the same setup works in the editor.

Also the project is upgraded from version 4.9.2; and the package works on the version?

I have been able to reproduce your issue when I converted the project up from 4.9.2, and I am continuing to investigate this issue. I will respond with new information as soon as I can.

I apologize for the delay.

Have you tried recreating your Open Level nodes when you convert the project to the newer version?

I’m working on upgrading a project through a few versions, but I’ve currently been seeing some inconsistent results. Have you recreated a simple open level setup in a new project? If so, what was the behavior that you were seeing?

I have tried and it acts the same way.

Could you please provide a screenshot of your widget blueprint’s Designer tab? One thing that fixed this issue for me was to resize the canvas panel to custom, and then back to fill screen, or vice-versa if you already have it set to custom.


I am marking this topic as resolved for tracking purposes, as we have not heard from you in a few days. If this issue persists, feel free to respond to this thread. For any new issues, please create a new Answerhub topic.

Have a great day