Packaged Game Won't Start- "Unknown Method"

I’m using UE4.9, on a project converted from unreal 4.8. My operating system is windows 10 64-bit, and I’m shipping for 32-bit windows. I initially had some problems with an asset with a name that was too long to cook, but I’m pretty fixed that by deleting that asset plus the .uasset file, and importing the same file with a shorter name. Now it cooks and packages just fine, but the game won’t launch.
Here’s the story:
I built the project for 32-bit windows, it worked fine. I tried launching the exported game, but it wouldn’t start, the cursor just kept spinning. I know Unreal games can take awhile to start up, but I left this for an hour and it still didn’t launch. No explanation given. I gave it to my friend to test on his system, and this is what popped up for him.

Can anyone help me with this? I have no idea what to do.
[Here’s the link to my game][2], and [here’s the link to the log][3] (sorry, too big for pastebin!)

One thing I noticed was this message: “[2015.12.03-04.33.03:704][577]MainFrameActions: Packaging (Windows (32-bit)): UE4Editor-Cmd: [2015.12.03-04.33.03:394][ 0]LogSavePackage:Display: No exports found (or all exports are editor-only) for T_UNV_Concrete02. Package will not be saved.” There are tons of messages like this one, could that be causing this?

Any help would be much appreciated, thanks!

It seems to work on some machines, as another friend was able to run it with no problems. I’m trying to reinstall visual studio, when I tried to launch from the editor it spouted something about duplicate metadata.