Packaged game Screenshot only stretches

When I take a screenshot from the editor with the command HighResShot 7, the quality of the image increases just like it was rendered in a high resolution. However using the same command on a shipped build only stretches the image thus does not provide any visual enhancement on the image.

Hey Naocan,

I am not getting the same results you are reporting, although my video drivers are crashing when I use the ‘HighResShot 7’ command. I can get all the way up to a multiplier of 5 before I get the crash.

All the multipliers I tried however did not produce any sort of stretching. Would you mind providing me with you ‘dxdiag’ so I can take a look at your system specifications.

Thank you,

Hello Andrew,

On the link, you can find our exports. I uploaded them to a third party website due to the immense sizes of the screenshots. In the file you can also find the DXDiag data.

The file named in editor is taken from the editor in PIE, thus has lower resolution as it was taken within the window, not the immersive mode or fullscreen. Even with the difference in resolutions, the editor output has much more quality. It is quite identifiable when zoomed in.

Could you provide me with a screenshot of ‘Play’ settings in your ‘Editor Preferences’?

I have a feeling that the resolution in your viewport could be higher than the standalone, which means you are multiplying a lower resolution image, which is why even at a high multiplier you have some blurring.



By the way to avoid any misunderstanding if there are any, the low quality screenshots are taken from a packaged game, in development build (Shipping yields the same results) in Fullscreen mode.

There is no misunderstanding. Notice how the ‘Standalone Game’ window size 1280 x 720?

Try setting it to 1920 X 1080 and then using that resolution in the packaged project to try the console command again.

Let me know your results or if you have further questions.


No, unfortunately it does not do the trick. Also it made me wonder, why does an editor preference affect the final shipping content?

Edit: Now realized that the stretching only occurs with Fullscreen command. I have ran various tests and here are the outcomes:

Editor - Normal: Good quality, lower resolution due to viewport size

Editor - Immersive: Good quality, intended resolution due to native viewport size

Standalone - Windowed: Good quality, intended resolution if the window size is the same as native

Standalone - Fullscreen: Bad quality, intended resolution.

As a workaround during the screen capture I will switch to window mode, take the screenshot and switch back, however this part unfortunately needs a touch.

Keep in mind you can use the HighResShot command to take a much higher resolution screenshot image. You can also use the High Resolution Screenshot tool in the viewport which gives you more control over the resolution and area in which you want to take a screenshot.

Taking Screenshots in Editor

Take a look at the documentation link I have provided to see if that helps you as well.

The final test case you have listed under standalone, could you provide me with the simple steps you are taking, the native resolution of your own screen, and the values you are entering for the standalone window size?


I am simply running the command “HighResShot 5” from the Execute Console Command node via blueprints.

My native resolution is 1920x1080 and I am entering the same amount from the Editor Preferences.

I am writing down the exact procedure for recreating the issue. Also I would like to state that me and my workmate are having this issue on three different PC’s (4790K with 980Ti, 5820K with 970 and 6700K with 970), all using 4.10.4. Also we also tried inputting the console command manually (Not using blueprints), no difference. On the examples below, I’ll state them as button “K” for executing the command.

  1. Good quality screenshot from PIE Normal:
    Run from PIE, Press K. Adjusting the size of the window changes the resolution but does not mess with quality.

  2. Good quality screenshot from PIE Immersive:
    Switch to Immersive mode on editor, Run from PIE, Press K. Results with good quality.

  3. Good quality screenshot from Standalone window mode (1920x1080 from editor settings screenshot you have posted above):
    Press standalone game, Press K. Results the exact same as 2.

  4. Bad quality screenshot from Standalone fullscreen mode:
    Press standalone game, press Alt+Enter. Press K. Quality is completely bad and its like it is resized from mspaint just like in the picture I have provided.

  5. Bad quality screenshot from Standalone fullscreen mode:
    Press standalone game, from the console type: “r.setres 1920x1080wf”, after resolution settles in, press K. Same result as 4.

So I am not getting the same results. Could you clarify steps 4 and 5, because you mention standalone windowed mode in number 3, but 4 and 5 also say Standalone mode which could mean launched from editor or the packaged project.

In any case, I tested both issues and did not experience the same results. Honestly, your best bet would be to use any of the screenshot variations that work correctly. If you are running on a 1920x1080 screen like mine, and have entered that values I provided in the editor preferences, your standalone game should launch in fullscreen by default. You shouldn’t need to use a console command at this point.

I would also like to point out, unless you are creating a giant poster, using HighResShot 5 is going to create a 9600x5400 resolution image, which won’t be useful unless you are on a 4k monitor, which even then you won’t be able to see the difference in images quality compared to a lower multiplier like 3.


All the standalones in this test is from the editor currently. So a single recreation of Standalone game from editor, alt entered are expected to give bad results. As I found out that the main issue comes from window-fullscreen, I did not test the packaged content. I am not sure if you are entitled but I can even make a demonstration via any screenshare methods because it probably is the most crucial feature for us and a definite dealmaker.

The photo is either going to be used for a giant poster or be used by zooming into the details. Either way, I hope you can recreate this. Thanks for the help so far as well.

Edit: Entering 1920x1080 does not make the standalone game from editor to launch in fullscreen mode. It is just windowed with native resolution that has upper bar which minimize, maximize and exit are located.

When you go into the ‘Editor Preferences’ and set the ‘Standalone Window Size’, there is another field called, ‘Additional Launch Parameters’ where you need to enter ‘-Fullscreen’ which will launch your standalone game into fullscreen mode.