Packaged Game on other PC = Black screen

Hi! I packaged my game for ‘Development’ and now we’re having a trouble : when we install the Pre Reqs (or WTF is it), we launch the game through the .exe file it launches but there’s nothing happening just black screen. It’s working on my PC but only on my. Any help?

Hi BimbawZ,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project in particular?
  • Have you set the maps and modes information to load a particular map when you first open the project?
  • What are you packaging to?
  • Have you made sure to build lighting before packaging the project?

Yes, I built lightning on every single scene. Im packaging to school competition we just need it to get working. I ve set the maps to… first main menu and from that you are able to get into other maps. Its in a project with content - as i mentioned for scjool competition. It has about 7gb in packaged size

Does the project work in PIE and launch or do you see the same black screen in both of these scenarios as well? What are the exact steps you are taking to package your project?

In PIE all works fine, as well as I package for development. But development doesnt work on other PCs. I followed steps from docs the article Packaging. Now if i package for shipping i cant play it in packaged game because it says failed to open descriptor file. I have win 64 and i tried both of them but still dont know…

Where did you set the maps at? Specifically, make sure you followed the steps here:

If this is what you did already, Are you able to reproduce this in a clean, blank project with no additional content or is it limited to the main project?

I followed these steps. But i dont understand second question

If you open a new project, are you able to package that new project and see the default map or are you only able to see a blank screen?

If I package for the Shipping it says the same as with our project - descriptor file failed.

i tried with Development settings and it launched properly (at my PC, and the Shipping was also on my PC)

Can you post the saved logs here from the packaged shipping build? Additionally, if you could please upload a sample project that this is occurring in, I’ll be happy to test it on my end and see if I get the same results.

I probably fixed the problem - when i disabled Substance and created new project, packaged it for shipping it worked without error.

To confirm, the error you were experiencing is no longer present if Substance is removed? Are you currently using Substance in the project?

Nope im not using substance in engine anymore

I’m happy to hear you are no longer experiencing the black screen, it should be safe to remove the substance plugin if you are not using it. I’m going to mark this as answered for tracking purposes. If you experience this error again after the plugin has been removed, please post back here and I’ll be happy to take another look.

thanks anyway :wink: