Packaged game needs a Mouse Click to focus Window and start Rendering

When I run my game from within the Unreal editor everything is fine. However, when I run the packaged build, the window opens up but remains black, nothing happens, and the nouse cursor stays visible. However, as soon as I click into the window, rendering “starts” (i.e. game graphics are shown) and the mouse cursor is hidden.

This is in particular bad, because the splash screen (video) we show at game startup is not shown. When I then click into the game window, then the splash screen animation is shown, but not from the start, but somewhere in the middle of the animation (depends how long I wait until I click on the window). If I don’t klick at all, then it stays black forever.

I have the impression this started since 4.9, but I am not 100% sure on this.

Any ideas?

What happens when you start the game in fullscreen mode? :slight_smile:

Exactly the same – the game starts, but the screen stays black until I click with the mouse.
Apparently this seems to be a known issue in 4.9:


When I deselect those two options mentioned in this thread, it works for me again.