Download

Packaged game loads too slowly, how can I speed it up?

When I run my packaged game it takes just over 24 seconds to load up and start a completely empty map with a default Pawn with nothing in it.
What is it that takes so long?

What can be done to speed that up? I would have thought it should be able to start up in a couple of seconds?

Cheers
Fred

Part of it will depend on the speed of your PC, including hard drive performance and RAM speed, but the engine isn’t exactly a light engine so it’ll take some time anyway.

Hmm…its a bummer as I’m making a VR game and it leaves the player standing around staring into darkness for too long.
I tried the Unreal versions of the VR splash screens that I think is meant to help but they seem too buggy and break things instead so I can’t use those.
Would be nice if at least I could get a vr splash screen or level displayed instantly.

What’s your PC specs?

i7 Quad 3770, 16GB DDR3, gtx970

That really sounds unreasonably slow. My packaged project takes less than a second to load a mostly empty scene.

Even on the first go? Ie including launching the game from the .exe?

Yeah, from clicking the exe to the main menu being fully loaded on screen with backgrounds and gui and everything takes less than a second.

Though it might have something to do with me using exclusively m.2 ssds… no slow hard drives get near this pc.

There must be some serious bug in your packaged game. I got a VR game here that is 2GB packaged and the loading time on my low end crap pc is something like 5 seconds - and that is with a nearly broken antique HDD that still has these spinning discs and is fragmented like hell.

On my Laptop with SSD it takes like a two seconds to load. And again - this is not an empty map but a 2GB game with VR.

So i think you have some serious bugs or problems, this is not normal.

Try to disable package compression.

Thanks everyone for the tips. Good to know that it definitely shouldn’t be as slow as it is now.
It also made me think to turn the EDL (Event Driven Loading) back on. I was advised by an Epic staffer to turn that off to get my blueprint Nativization to work, which it did.
But I am now noticing it makes a huge difference to the load times.

Bad news for me if I have to choose between long load times or slow blueprints.

Cheers
Fred

You can take a look at your packaged build with umodel, http://www.gildor.org/en/projects/umodel and see if anything is unreasonably large. This utility can be helpful for identifying outliers that might be causing weird load hitches.

Interesting tool.
Thanks, I’ll take a look!