Packaged game has many issues while game in editor works fine?

I finally have everything setup and ready to go for a first demo release.
Then I packaged my game. And sometimes the UMG doesn’t work…and some times my would be off time then it was. All these things work perfectly in the editor.
What would cause all these things to go wrong??

Is it possible that performance messes with the packaging?
I’m using a gtx 770. 12 gigs of ram. i7 8 core processor…I never have any problems…
I don’t see why it wouldn’t package the way it played in the editor…If be more than happy to have someone look at my project…or I dunno. Anything. Irs completely ready to go in the editor.

Or is there someone I can work with

Someone has to know something!! I see people with this issue regularly and some of them DONT get solved…which is not something I want to do
I’d like to release this to the public.
Someone please help.

I just need some things to try. I HAVE NO idea about this issue.
I apologize got my frustration. I just thought I was finally finished.
I’ve only packaged for shipping…should I try for development? Does that make a difference? ??
And are there any settings I should consider looking at???
is there anyone that would take a look at this project for me?
It’s only a couple gigs right now…
I really wanna release this.

Now looking more into it some of it was a timing issue I added a half a second delay to couple things for it to run in time for the packaged game…
But the HUD no matter what I do is messed up…I change one node and it all works…but I tell a certain image to change and they all disappear and once it again. This DOES NOT happen in the editor

This one sounds special… unfortunately I’ve no experience packaging but as one day I’d like to package my own game without fear of UMG blowing up I would like to see this resolved.

My suggestion: Change this posts title to be more declarative and informative: “Packaged Game is broken while editor game works fine” or something like that… “missing functions” is not very informative at a glance.

Secondly retag it as “bug report” and also move it to the section “Bug Report” (click the more button and select change space or something like that). That way a member of the epic staff may be able to answer your question and help you out directly. (will usually take a day or more…)

I’m gonna do that now. Thank you. :slight_smile:

And for more information on the deal I’d be more than happy to look into and learn. I just don’t know what it means if the packaging doesn’t come out right. If there’s some sort of debugging or different blueprinting I Could OR SHOULD Learn How To Do I’d Be Happy If Someone knows where I should look…

I have an update to this.
After changing some of my UMG images that I made in gimp from 1024 scale to 512 they worlds.
i dunno If anyone knew that but sometimes after packaging its not picking up any images on UMG with a higher power of 2 then 512.

effects quality being changed via console commands for like graphic settings can be sketchy.
If you set the effects quality to 0 It kills any background music I have playing. ONLY in the package.
I had set up graphic settings and when I put it on low the music would stop.
it ended up being that console command. effects quality. it can’t be changed to 0 or the music would stop.

those are the couple bugs I’ve fixed by just debugging the project.
I’m still not sure what happened to delay times and rotate times because they are all slightly off.

Just an update. Still hoping somebody gets with me soon. thanks.

Hi ,

I’ll be more than happy to help, though it seems you have quite a bit going on all at once so we’ll tackle it piece by piece. What devices are you packaging for? If mobile, have you made sure you have the proper .SDKs installed? What settings are you using to package?

Thank you sir. It’s being packaged for Windows. I have it set to development and full rebuild is always checked.
I know when the Game is played on on another computer it Installs something from Microsoft Visual . On My PC it has never done that. Is that normal?

Is there any other information you need to assist me? I haven’t solved anything.

What does it install from VS? If it is the runtime for C++ that is expected. Can you send me your dxdiag so I can take a look? Thank you!

Yes. the run time C++. I dunno Ill I know is if I package the game and then go on my desktop and play it I don’t have to install that, when everyone else does.

And can you tell me how to access this dialog so I can get it to you?

To get your dxdiag:

  1. Open Windows Start Menu
  2. In searchbar, type “cmd”
  3. Open the command prompt program that appears in list
  4. In command prompt, type “dxdiag” and press enter
  5. Save the information to a text document and post that here.

Hello, I just want to chime in that a project I am working on is also having UMG issues in a packaged project.

The UMG works fine in-editor, but will disappear in the packaged game.

The disappearance happens when ‘Set Visibility(Invisible)’ is called on a UMG element. When this is called, that specific UMG will no longer have anything to draw. This in turn will cause all other UMG elements to no longer draw.

Edit: Some more info. The UMG in question is using non-Power-of-2 textures. They are 100x100

I had a similar problem. I changed my scale to 512 on all images and everything works. I’ll have that file for you too . Weather conditions are slowing us down right now.

Hello ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Helpful information that could be included in the next post if this issue is still occurring:

  1. What version of the engine are you using?
  2. Can you reproduce this issue in a clean project?
  3. If so, could you provide a detailed list of steps to reproduce this issue on our end?
  4. Could you provide your dxdiag?
  5. Could you provide screen shots of the blueprints that are involved with this issue?

Thank you.

Thank you so much. As it was a demo and there was only a slight issue I let it go for the time being. I’ve tried recreating it and it didn’t give me any problems. Honestly after I updated to 4.7 it seemed to not give me the problem. Thank you for following up. I appreciate it.