Download

Packaged Game Executable Not Working (Win x64)

Hello! Not sure if this is the right board for this, none of the categories seemed applicable, but I’m having issues with a packaged project using 4.24.2.

In 4.23, I could package my project and then run the executable that is created in the WindowsNoEditor folder to launch. Now, when I launch the executable, I get the following error:

Has anyone else encountered this error?

Here, the same!

I package the same project in 4.23 and It runs. And When I pack it with 4.24 it creates the file but it doesn’t execute.

I think 4.24 is better for performance and I wish i could migrate my game, but this issue sucks!

Hey, guess you’ve already tried it, but have you double checked all of your project packaging settings… I’ve had project settings reset or change a couple of times when upgrading to a newer ue4 version in the past… Also maybe try/enable Full Rebuild and possibly disable For Distribution…?

Well, it never happened to me before.
I always make a build of my game after upgrading to a newer version, to be sure it’s working 100%.
I never completely upgrade the project to a new version before I see it’s 100%, always keeping a copy of the previous version.
Now I wish i could migrate to 4.24 for it’s faster building and optimization improvements. :frowning:

Hi. I had the same problem. For test purposes, I made a build of the Product Viewer Template back from 4.21 (now part of the Collab viewer template) without making any modification to it. Unfortunately I modified 2 settings for a second build, enabling Full Rebuild option in the Project Settings and switching from Development to Shipping, so I can’t really know right now which one has solved the problem, but now my build is working fine.

I’ll try to make a third build switching back to Developement, to find out which modification really solved my problem.

I’m using 4.22, and Project Settings switching from Development to Shipping and success.