Packaged error on startup

My game works within the editor when I press the Play button, but if I try to use the Launch button or package the game I run into issues. It is able to create everything, but the moment I try to run it I get the following below.

I am not sure what to do. I have UE4.7.2. I’ve tried removing all navmeshes from my map, but it still does the same thing. Any help would be appreciated. Thanks.

TestingGround.exe!FRecastTileGenerator::GatherGeometry() (0x00000001413c96ac) + 222 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\engine\private\ai\navigation\recastnavmeshgenerator.cpp:1530]

TestingGround.exe!FRecastTileGenerator::Setup() (0x00000001414061a8) + 0 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\engine\private\ai\navigation\recastnavmeshgenerator.cpp:1507]

TestingGround.exe!FRecastNavMeshGenerator::CreateTileGenerator() (0x00000001413a4137) + 0 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\engine\private\ai\navigation\recastnavmeshgenerator.cpp:3433]

TestingGround.exe!FRecastNavMeshGenerator::ProcessTileTasks() (0x00000001413f491f) + 20 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\engine\private\ai\navigation\recastnavmeshgenerator.cpp:3453]

TestingGround.exe!FRecastNavMeshGenerator::TickAsyncBuild() (0x000000014140c231) + 0 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\engine\private\ai\navigation\recastnavmeshgenerator.cpp:2991]

TestingGround.exe!UNavigationSystem::Tick() (0x000000014140be28) + 0 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\engine\private\ai\navigation\navigationsystem.cpp:672]

TestingGround.exe!UWorld::Tick() (0x0000000140f7664a) + 0 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\engine\private\leveltick.cpp:1086]

TestingGround.exe!UGameEngine::Tick() (0x0000000140df4725) + 0 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\engine\private\gameengine.cpp:830]

TestingGround: TestingGround.exe!FEngineLoop::Tick() (0x000000013f6ae48d) + 0 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\launch\private\launchengineloop.cpp:2257]

TestingGround.exe!GuardedMain() (0x000000013f69fa8c) + 0 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\launch\private\launch.cpp:142]

TestingGround.exe!GuardedMainWrapper() (0x000000013f69fada) + 5 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]

TestingGround.exe!WinMain() (0x000000013f6b02d9) + 17 bytes [c:\program files (x86)\unrealengine\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]

TestingGround.exe!__tmainCRTStartup() (0x000000014254c2ed) + 21 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

Howdy cvax,

Thank you for reporting this issue. I am going to need a bit more information before I begin investigating this issue. Would you be using a source build or a binary build of UE4? Would you be able to replicate this issue with a blank template project?

Would you be able to attach any additional logs to this post? What platform are you attempting to launch on to?

Any additional information would be greatly appreciated.

Thanks and have a great day!

Hi Sean,

Thanks for the quick reply. I have tried on both source and binary builds of UE4. This is the only project I am able to reproduce the issue on. Blank and other projects seem to package fine. The packaging itself seems to go without a hitch, it is only when I launch the executable does it crash.

Attached is the Output Log from the Editor when I package the project. I am packaging to Win64. Development or Shipping both seem to exhibit the same behavior. If there is another log somewhere I can definitely attach it, but would need some guidance on where exactly to locate them. Thanks!

Edit: Some more info.
I tried my project back with UE4.5 binary and it is able to package the project and execute without an issue. Originally I had migrated this project over from 4.5 to 4.7. I went back to the original non-migrated 4.5 version and the packaged executable is playable without crashing.

Hey cvax,

Thanks for the additional information. I have looked though the log that you have provided and I was unable to see any significant errors that could be causing the .exe file to crash.

Would you be able to share you project so that I may be able to test this issue internally? If you would like, you could share it privately via forums. Here is a link to my page:

Thanks and have a great day!

Hi Sean,

I sent you a private message on the forums yesterday. Thanks!

Howdy cvax,

Thank you very much for sharing your project. I was able to recreate the fatal error crash that you have been seeing. I have entered Jira Report UE-11433 and placed this report into our bug database so that this issue may be addressed in a future release.

At this time, I am unsure as to when that release will be but I will be sure to keep you updated as I see any work being down to this Jira report.

Thanks and have a great day!

Hey cvax,

I’m looking into it.

As a workaround can you make sure RecastNavMesh's properties match between Project Properties and the instance that’s on the level? Which one is it - you want runtime navmesh generation on or off? Level’s instance has it enable while the default properties want it disabled.



Hi mieszko,

Thanks for the tip. I will try it, but am running into a huge problem even loading the project now. I am using the .zip I shared with you guys (the clean 4.5 project that used to work), but when trying to load it up it in 4.5 to see if the RecastNavMesh settings were different between project vs level instance the project loads up blank. The Content Browser has all the content listed, but none of the content is accessible. Loading the project in 4.7 does the same thing too now. Loading used to work just fine. This seems to be the only project I have suffering from this and I have no idea what exactly changed to cause this.

The only thing I can think of that is different from prior to now was that I installed FMOD. I removed everything related to UE4 and reinstalled to no avail though. Any ideas on how to fix this? Attached is the Output Log. It can’t seem to find anything…

One thing I notice that is different about this project versus a previous copy that can load all the assets is that in \Saved\Config\Windows\Engine.ini there is a “Paths=…/…/…/…/…/Users/Josh/Documents/Unreal Projects/TestingGrounds/Content” with five “…/”. The newly generated one from the backup zip is now generating the path with six "…/"s. I have no idea how to fix this issue or why it is even happening to begin with. Any help would be appreciated. Thanks.

Edit: I’ve really screwed things up now. I replaced my map uasset from my working 4.7 project with one from my original backup and now it says it can’t find the asset even though I see it in the Content Browser. I even tried to rebuild the asset as per this Old Sample Content in UE 4.7 [IMPORTANT] - Announcements - Unreal Engine Forums to no avail. For some reason everything from the backup no longer works when copied to a new project.

I suggest you created a new answer hub thread regarding your loading issues - I’m unable to help you with that.

But first tell me if you want runtime navmesh generation to be enabled or disabled in your project?

Disabled. Thanks!

So the good news is that when I disabled runtime navmesh generation on the level’s instance of RecastNavMesh (and therefore made it consistent with project’s setup) and packaged the project it no longer crashes. Of course it’s still a bug, but not as critical.

So, once you solve your other problem that’s your fix :slight_smile:

Take care,