Packaged app runs on local machine, not on my other machine

Hi folks.

UE 5.1
Windows 10 / 11

Both machines have UE 5.1 installed.
Dev machine is Windows 11
Other machine is Windows 10

Hoping someone might have some insight into what’s going on…
Thanks in advance!!!

I can run a packaged game just fine on my local machine
I can move my packaged game to a different drive on my local machine and it will run. (Could be a fluke, not sure based on the the weirdness I’m seeing below. )


If I copy my packaged game to my portable hard drive and while still connected to my dev machine, I get this error

If I copy my packaged game over to my other machine entirely, I still get the same error.
UE Runtime Error on Client Machine

If I change the build type to Release, I get these two errors
Failed to find map

Hey @m00nB33r!

It looks like a bad copy happened… it’s saying it can’t find your map/level. Have you tried copying multiple times?

One thing you should try is compressing the original and moving it as one file. That way you only have one thing that can screw up :stuck_out_tongue:

Those things tried, I’d try to rebuild and give those things another shot. Tbh building is a process that can be iffy, but your error here looks like a lot of missing items, not a bad build.

Hi there Mind-Brain…

Yes, I’ve tried this multiple times. I’ve even gone as far as deleting all the generated files, visual studio files, regen the visual studio files, rebuilt the game repackaged it.

I have NOT tried zipping everything up though. HOWEVER, I did compare folder disk size between the Build/Windows folder and the Windows folder I copied onto my other machine.

The fact that the map is missing is odd, I’ve double checked in the Project Properties, it’s there…

Not sure if I mentioned this yet already, but this was working fine, all I’ve been doing is adding more game play mechanics to it…

It’s a client server game, but using STEAM as the sever… I’ve also made sure that I set # of players to 1, and set Net Mode to Standalone and not Listen Server. Change those up as I’m doing local dev…

It’s odd, not sure what changed, but something clearly changed.

I only get that LONG list and the missing map error when I set the build to a Release build.

If I use a debug build, then I get the missing material error…

WAIT did you add the map to the package? You have to specify what maps get packaged in project settings! It might solve at least one problem! Just open project settings, search “map” and check the results, it should be there somewhere.

As far as the materials go, it looks like they’re all located in /Engine/. I might be crazy but I believe there is something you have to do to make the engine items get packaged.

Yes I did add the map to the package, in Project Properties. I have a few maps in there.

About the material, not sure… I have not messed with the materials since long before this even stopped working… I had copied a packaged project over to the other machine many times since I ever edited the map itself. Everything I’ve been doing is in C++

Just a gentle bump for help! :slight_smile:

Hey @m00nB33r!

Just checking to see if you tried the compress to .zip, move, unzip on target machine method yet? I know you checked the map build, but I wasn’t sure if you gave that a shot?

Hey there…

Zipping up and moving it didn’t help. In fact my zip file ended up corrupt somehow.

So, I just copied the full build folder over by connected to a shared drive directly. Took a tiny bit longer to copy over, but that seemed to work.

@m00nB33r That seemed like the best call. I was pretty sure it was some kind of file corruption happening. You may need to look into that! :grimacing:

Yeah seems strange, but… At least I got past it!
Thanks for the suggestions.

1 Like