Packaged Android APK installs, but doesn't come up in the app drawer

I’ve packed out my APK with a keystore, ready for release - I do a shipping build and run the Installer script. It goes through it’s process with no fails, and says ‘Install successful’. And yet, in the app drawer, the app is missing - the only way I can get it to build out is by launching with the device manager - the app remains in the drawer after that.

This becomes problematic for doing builds to devices from another city! :stuck_out_tongue:

Hey Sythen,

  • Are you on a source or binary version of the engine?
  • What type of device are you having trouble with?
  • Does this happen on every device you attempt to install the program on?
  • Which version of the engine are you on? 4.11.2?
  • Can you upload the output logs from the engine, as well as any logcat files for the device?
  • What Android version is your device on?

To get logcat files:

  • Attach your phone to the computer
  • Go here: C:\NVPACK\android-sdk-windows\tools
  • Open up Monitor.bat
  • Launch the program and save the logs

If you cannot get Monitor.bat to open, please go to:

  • C:\NVPACK\android-sdk-windows\tools\lib\monitor-x86
  • Open up Monitor.exe
  • Follow the instructions above

Make sure that you highlight all of the logs, because they do not save unless they’re highlighted.

Thank you!

1 - On a binary version

2 - Galaxy S7

3 - I only test on a Galaxy S7, but I’m working with 4 of them - and the same result happens.

4 - Engine I’m running: 4.11.2

5 - Android 6.0.1 - Build Number: MMB29K.G930FXXU1APD1

I’ll try to get the logs, but this happens with the installation process from the bat file, and not from running the app itself. I’ll try though and post them here!

Would you prefer pastebin?

You can upload any logs here on AnswerHub as a .txt file. Provide as many logs as you’re able to. In the meantime, I’m going to try and replicate this. Have you been able to get this to happen with another project?

Thanks!

Hey Sythen,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!