Package my vr game

hello, I finally finished my first VR Game on Unreal and i want to package the whole thing. however I’ve found a persistent error… I’ve been looking thorough this forum and haven’t found an answer… im putting the error message below.

P.S. I want to package the game on windows 64 bytes.

Here’s the error log.

Looks like your Target.cs file has some syntax issues which prevent UAT from compiling it properly. Did you have a look at it? Was it modified by someone?

As Marco has said, the Target.cs is the issue and you can open these files from Source->

You can also try deleting the intermediate folder and re-generating your project. This should highlight any issues with the .cs file and might get rid of the issues.

Not at all, I never even touched that file

As Dune suggested below, first make a BACKUP copy of your project, then delete the Saved, Internediate and Build folders from its root. Right click on the .uproject file and select Generate Visual Studio project file. Then open the project and watch the Intermediate files being re-generated. Now try packaging again.

Hey Dune, I tried deleting the folder, then restarting unreal so I can package it… Unreal created the file as soon as I re-open it, so with the new file I tried packaging again… here’s the log… I think it’s pretty much the same as the older one… but I really dont know, would you mind take a look a it please?

Tried it already, deleted the Saved and Intermediate folder only, cause I couldt find the Build one… after I did that i tried right clicking to “Generate Visual Studio” but an error window appeared… which is the image below… after that I just clicked accept and tried to package the game anyway… same result and error log as before.

That error is normal because I see that you don’t have any Source in your project folder. Since you still get the error, I am thinking that your .uproject file contains some stray dependencies. Can you attached a screenshot of its content? Open it with Notepad.

Sure Marco, here it is… Sorry for all the trouble tough :confused:

Looks ok to me. Here is the next thigh I would try.

Create a brand new empty project. Call it Test. Save it.

Now open this project. Select the level (map) from the browser. Right click and choose Migrate… Migrate the level and all its dependencies to the Content folder of the Test project above.

Open the Test project and try to Package that one. Does it work?

Sorry to tell you Marco but what you ask me is impossible, the map never loads in the other game, I just waited for 2 hours and nothing happened… any other suggestions?

I believe your project is corrupted beyond repair. One last thing you can try is take the content of the Content folder and copy it to the Content folder of a brand new project. You may be able at least to recover the contained assets, but not sure whether that is going to work. Sorry! You may try to get help directly from Epic. Maybe they have a trick to fix it.