Package game has incorrect icons in Windows UE4.21

I make sure that my game icon and my copyright information are all there in the Project Settings. But after I package my game:

WindowsNoEditor\Game.exe has correct explorer icon, but when I open it up, the icons on the task bar and the window bar are all UE4’s default icon, what’s more, the copyright information of this exe is also UE4’s default copyright information

WindowsNoEditor\Game\Binaries\Win64\Game-Win64-Shipping.exe has no correct icons and copyright information, which means, its icons in the explorer window, on the window bar, or on the task bar, are all UE4’s default icons. Also its copyright information is UE4’s default.

I’m running Windows 10 64-bit, Unreal Engine 4.21.1

I’ve tried a lot, but nothing changed. It takes time to edit those exes using third party software, but anyway, it’s UE4’s bug isn’t it?:slight_smile:

I’m having this issue too.

Well, I tried to package the official Shooter Game demo using UE4.21, its icons and copyright information are all right. And I’ve found that the demo actually have an rc file in the code project which defines the application icon and other things. However, this rc file does only affect ShooterGame-Win64-Shipping.exe, and the ShooterGame.exe has right icon but wrong copyright information. So I’ll first set up a resource file for my project and wait for the developers to focus on this issue. :slight_smile:

OK. I found this in the known issue : UE-67032. Now the fix is available in the dev branches, and it will be fixed in UE4.22. Awaiting.

no workarounds until 4.22 is released? surprised this isn’t more of a big deal for more people, as i’m having a hard time with it… a few engine versions ago i got it working…

Try third party resource tools to modify those things. I’m now depending on this way.