Package Failed when any non-default plugin is enabled

Hi there. I’m trying to enable some plugins on my blueprints based project but whenever I enable any plugin that isn’t enabled by default, my packaging always fails. I tried reinstalling Visual Studio 2017 with C++ compilers. I changed the default compiler in the toolchain project settings. Still getting package failed though. Does anyone know why this might be happening? I will attach my packaging log file. Thanks for any help in advance.

link text

@blastertoad Hey blaster, this has been troubling me for days and was wondering if you had an idea why this might be happening? Any help would be appreciated.

Hey Brylos-

Are the plugins being enabled provided by Epic? Which plugins in specific are you using? I tried enabling Online Subsystem Oculus and Online Subsystem Steam but did not receive any error when packaging. If you’re using a community plugin, you may need to contact the plugin creator

It’s anything that is not enabled when you first create the project. I started out by using a third party plugin (Advanced Sessions), figured it was that which was causing packing failing so I disabled it. Still got packaging errors, then I disabled the steam subsystem and packaging worked. To test it even further I tried enabling a random plugin that comes with the engine (Blueprint Stats) and I got packaging failed. I disabled it and packaging worked. I just tested it again twice to make sure I’m still getting the issue and I still am. Here is a more recent log of when the packaging fails and the only extra plugin I have enabled during this log is Blueprint Stats: link text

I enabled Blueprint Stats in a project locally and was able to package successfully. Can you reproduce this in a new project? If so, please provide the setup steps used.

Yeah I just created a new project, first thing i did was enable the blueprint stats plugin then restarted the editor for the plugin to become active. Then went straight to package project and it failed. Then for testing purposes I disabled the plugin, restarted, packaged and it worked. I recently updated my engine to 4.15 and imported my project to it. Could that be relevant?link text

Okay I figured it out. The issue was that I was using Visual Studio 2017 instead of 2015. I uninstalled Visual Studio 2017 and then installed 2015 with C++ compilers. I’m so glad that after days I’ve fixed this issue. Hope this helps anyone else that was having issues with packaging.