"Owner No See" Not working with new camera.

Hi,

I deleted the default character camera and created a new custom camera as a separate actor. I used “Set View Target With Blend” with “Player Controller” as the target.

Everything seems to work fine, except when I try to use “Set Owner No See” on components, it no longer has any effect. The components stay visible on the new camera. I did not have this issue when I was still placing a camera inside the pawn blueprint.

What am I missing here? How do I get the new camera to be recognized as the owner camera? Am I forced to use a camera that’s inside the pawn blueprint?

I appreciate any help I can get!

Did you ever find a solution to this?

Cheers.

Did you find the solution?

Instead of setting the owner to the pawn, I set the owner to be the view target of the player controller, like in the screenshot. This worked for me.