Download

Overriding Character Capsule Bounce-Off Physics

I’m working on a character object (it’s a battery) where you’ll jump on it to stun it and then you can push it around. The problem that I’m running into is with the default effect you get when you jump on a capsule. The game I’m making is 2.5D, so the character cannot move forward or backward, but sometimes when jumping on a capsule, they’ll be bounced forward or backward, which is bad.

So I’ve tried to override this by shrinking the capsule and adding my own box collisions to the character with BlockAll collisions and then OnHit launching the character on solely the X and Z axes; however, this seems to have had no effect. The player still interacts with the capsule collision instead of the box collisions; for instance, if I disable the launch node and just have the block all collisions, the character still bounces off of them as if they were the capsule collision.

What do I need to do to disable this effect?


I’ve tried to disable the collision on the capsule completely, but the character seems to ignore the collision boxes that I’ve added when it interacts with the ground. If that’s disabled, it falls through the ground. However, I can see that I do collide with the boxes if I walk into them as my main character.


Furthermore, I disabled the collision on the capsule, reduced all force factors in the character movement component, disabled physics interaction in the character component, and disabled gravity on it so it wouldn’t fall through the ground, and I’m STILL being bounced off of it.


Setting the mass to 0 also didn’t work.


I can confirm that all box collisions are behaving as the capsule does now. If I add a BlockAllDynamic box collision beside the character and jump on that, I’m bounced off just as if I’d jumped on a capsule. How do I disable this behavior?

Alternatively, is there a way that I can constrain the default bounce-off physics to only move on the X and Z axes?

Did you ever get a solution to this? I’m making an adventure / puzzle game and it relies on physics objects, moving them, stacking, climbing on them… However i get propelled like a rocket, or the object does too. My son figured out how to fly with this by grabbing hold of the object first and stepping on it.

In the component’s Collision section, above “Collision Presets” should be “Can Character Step Up On”. Set this to “Yes” (Default is “No”)