Download

Overlapping UV maps on meshes

So most of my meshes have an issue;

There is one UV inside the blender files and the UV faces are overlapping. The positioning is correct but there are clipping issues and when I build I get the overlapping UV maps error. My idea to solve the problem is create multiple UV maps in Blender and put different faces on different layers. My only issue is I’m not sure if this will work or how to exclude certain faces from each map. Any tips would be appreciated

If you’re doing texturing then it doesn’t matter if they’re overlapping if it looks OK for the textures.
If you are trying to set up the UV’s for your lightmap then they must not overlap and they have to be on the same UV channel.

Yes, multiple layers doesn’t help. You need to scale the UV triangles down and pack them all into a single UV sheet.
Typically, you’ll do this as the second UV channel – you’ll have one UV channel for material texturing, and a second for light mapping.

How do I assign the lightmap to the second uv channel? Should that be done in Blender or Unreal? Thanks for the help

In UE4 open your static mesh and type “Lightmap” in search tab of Details tab - a number of settings will be shown.
You can specify existing UV channel in Light Map Coordinate Index. If you want to generate UV channel from already existing channel then set properly source UV channel(Source Lightmap index) and UV channel where you will store generated data(Destination Lightmap index)

I created the second uv channel in blender and UE4 shows them properly in the mesh viewer. But whenever I build the lighting the UV still stay %50.6 overlapping even though visually they are not overlapping at all. 2 UV channels (0 and 1). I set the source lightmap index and the destination lightmap index as 1 but still it stays around %50. I got UE4 to generate the UVs automatically, when they appeared to be overlapping by a very small amount it still says it’s overlapping around %50. Whatever I do it seems to say they are overlapping.

still overlapping 27% even though they clearly aren’t overlapping 27%.

This is settings for auto-generation of UVs which is by the way disabled on your screenshot(Generate Lightmap UV’s). Also, settings like 1/1 are redundant because you’re generating from SOURCE(Which set to UV1) to TARGET(Which set to UV1 again). You should use different channels for effect. However, Auto generating of Lightmap UVs is only moving around already existing UV shells so it can’t fix some overlapping error.

During import disable auto generation of Lightmap UVs and let it import your Lightmap UV correctly, then be sure to set Light Map Coordinate Index(Not source/destination) to 1. If it still shows overlapping then you should just fix overlapping in your Lightmap UVs

It will still overlap a very small amount. The meshes are so complex and large that rendering the lighting was difficult. Clipping in project settings was the biggest issue actually. It looks pretty good even if the light builder logfile says there’s some overlapping. Not sure if that’s tolerable or not.

  • create a second uv map channel in blender

  • select every face

  • u - unwrap - lightmap pack

  • check there is enough space between uvs, you can control that with the margin parameter

  • when importing in unreal uncheck generate lightmap uv

hope it helps