Overlapping tree problem

Clearly I’m doing something wrong…
I’m in Paint Foliage mode.
I have 4 trees I want to paint loaded in.
If I select 1 tree and paint, no worries it paints fine and there’s no over lap at all. Iv t the radius set to 1000 and that’s great.
I erase that and select the second tree type. So now I have two tree types to paint with, Both set to 1000 radius… They over lap…
Not with their own type, but with each other.
I’m clearly missing something here, but I thought the Radius setting was supposed to stop foliage from painting close to each other based on the Radius setting?.

Ah… The Procedural Foliage system might be the solution here.
I’m not sure, I only looked at it briefly… But it might be my new favorite tool!