Download

Overlapping audio volumes plays sound twice?

Hello, lets say I have an oddly shaped river and I’m trying to add Ambient Audio volumes to it to give a river sound when nearby.

The problem is that in the sections where the volumes overlap, you can hear the river sound twice (from each volume).
Not having them overlap leaves too many gaps which is odd when walking near a river and it suddenly goes silent for a few steps.

Is there any way to link audio volumes to all share the same sound so they all attenuate together instead of individually?
Or some other way around this problem?

Thanks!

Use only one sound volume for the entire mesh, or code something to fade in/out the sound when you enter/exit each trigger.

Hi Juice-Tin,

This is a great problem to tackle and there are many different approaches one might take. For example, you can try making a Spline Actor that follows your River and then just use one Audio Component that moves to the closest point on the Spline Actor to your player.

However, with that approach, you will want to solve the problem for when the sound is actually two sources from the perspective of the player, for example, at the mouth of the C the two tips of the river will act as two sources, if you’re in the center of the C, it will act like one continuous source that spreads across your sound field except on the east side of the C.

I got around this in Ark by just using the audio with attenuation settings overrides. There was a good hand-off just using the “drag-n-drop” functionality of the audio with allowing it to be heard from X distance. It would hand off from one to another without playing more then 1 at a time per player. I have never used the audio triggers due to it just working with the simplest method. I was using “wave sounds” with some jungle birds and dino sounds with some really nice blends of the 2 when X dist. was achieved. When on the beach itself, it would play the wave sounds, when in the jungle it would be the jungle sounds. I think i had 14 beach ones in a row and it was a good hand-off with constant sound (no drops or double plays) …

Trying using the audio (the sphere you can change as well) and then make adjustments in the audio for how many to play, distance, attenuation, etc etc … that maybe easier then trying to use the audio box.

Ah, from the replies I can see there’s no built in solution to this.

Dan that’s an interesting approach! Although with a single volume, the mouth of the C would cause problems if the player ran back and fourth between the top and bottom. This would cause the volume to jump to either end making it bounce between left and right speaker.

Is there a way to make spacialized audio play as Mono? Meaning, it’s volume will still be affected by proximity, but it will play equally out of both speakers. This would fix the problem of the volume bouncing around when you run around the inside of the C.

Edit:

Hey AP_Studios, that’s exactly what I’m using. Drag and drop sounds with overridden attenuation. That’s what’s creating the 2 sounds when overlapped. I don’t see anything about how many to play though. It seems like we have the same setup except you have overlap with no double play?

I think what you’re referring to is the Non-Spatialized Radius. The source is mono if you play a mono source.

Thats correct, it would only play 1 at a time. Now i will have to remember back, because, i havent used it in a while (stopped modding Ark about a year ago, or more). I seem to remember there being an option about playing only 1 sound at a time, inside the sound settings. I am really sorry i cant give a better answer to this right now sinc i am not in my office to review.

It seems, and maybe it was just like perfect timing for thousands of users, that it would play 1, and, once i left that ones “space” the other would pickup where the one that stopped ended. It gave a very consistent flow. I do remember running into 2 at once by default, until, i changed a sound option.

I will have to dig into this, and again, i am sorry i cant give a better more detailed answer.

Sound Concurrency is a feature allowing you to group sounds which should have a maximum number of playing sounds with a variety of rules for how to determine which sounds to prioritize–but it’s not a gentle way to deal with this.

Yeah I tried sound concurrency though that won’t stop older sounds that are already playing. Ex: 1 looping sound will always take priority and the new one you walk into will be dead silent.

Anyway thanks for the info guys, I’ll be able to come up with something. :slight_smile:

> 1 looping sound will always take priority and the new one you walk into will be dead silent.

This is incorrect. There are a number of “resolution rules” you can choose with sound concurrency groups. One of them is “stop oldest”. This will stop oldest sounds and allow newer sounds once the concurrency limit is reached. The default rule is “prevent new”, which would have the behavior you’re describing.

Hi! How to do this? Is this a sound class function? I need to create sound concurrency.

Make a new sound asset called “sound concurrency”. You’ll see various options.