Download

Output of this float * float is always 0

I’m not sure what’s going wrong. I’ve even tried setting through a solid 1 (INT) * float (axis) and even after setting a variable and then using that variable for this operation it’s still outputting 0 after trying to multiply it.

Are you sure its 0? Try using a Print node to make sure that it isnt. I dont trust the visual debugger to always return what im expecting. As a rule of thumb always double check with 2 different methods if possible if you cant be sure.

The Input Axis will return a value between 1 and -1, which includes 0, so multiplying by 0 will always result in 0.

Yup. print string said that it was behaving as normal xD maybe having the visual debugger running “on tick” was too much? I don’t know. I didn’t realize that the debugger is unreliable at times. Thanks for that tip for the future though. That said, my ball still isn’t moving left or right o-o It was doing fine until this happened but even though the value is correct it’s still not behaving properly. But that’s an entirely different problem I suppose.

Is acceleration "0"or it has value? And print it in runtime do not rely on what you set it to in properties.

The output of that node is probably not being used, and so is not being calculated. Can you show us the rest of the graph?