outdoor lighting technique

I’m somewhat embarrassed to even post this, as this scene looks horrible, but after many days of trying to find a lighting solution, I decided I’d try asking for help here in case I’m missing something very basic with lighting an outdoor scene. I’ve got all the vegetation seen in this scene from the Kite Demo, yet in my scene they look absolutely horrible. I’ve tried placing my scene into the Kite Demo, and most things look much better (other than my flag); but I don’t understand the different levels of lighting system there. I’m also wondering if the LOD settings on vegetation are set wrong but after messing around with screen size parameters, I can’t make them look much better, even when restricting everything to LOD0.

I’m using dynamic lighting–with a skylight, directionallight, Atmospheric Fog, BP_Sky_Sphere, GlobalPostProcessVolume, LightmassImportanceVolume (though I gather this doesn’t matter for dynamic lighting).

Thanks to anyone with some pointers…


I’ve never quite seen such a distinct difference between assets in the same scene. Your tree and building look almost unlit completely. I would troubleshoot one step at a time by first disabling your skylight. Then go from there and tweak the settings on your directional light to see if you have any issues. I don’t see any shadows on your assets, which is really confusing. The kite demo uses distance fields to do lighting and GI. Do you have distance fields calculated for your objects?

Thanks for your response StephaBon. Disabling the skylight only makes my shadows much darker, which is why I put it in the scene to begin with. I’m not sure why you say you don’t see any shadows on my assets, unless you’re referring to the building itself. I’ve attached some more screen shots so you can see the shadows, as the first one was taken on the sunlit side of the building.

I didn’t know about distance fields, so after reading up on it, tried experimenting a little in my scene. I’m not sure what you mean by “calculations”. I did try changing the DistanceFieldResolution from 1 to various other numbers up to 100; but didn’t notice any difference on the ScottPine mesh–this was after enabling “Generate Mesh Distance Fields” under the Rendering section of the project settings. I did notice a difference (especially with the ScottsPine) when I enabled “Affect Distance Field Lighting” in the Foliage instance settings. If I do this to the grass or ferns though, I get weird shifting pixelated shadows inside the building, even though no foliage casts shadows on the building–much less inside it.
This first picture is with the same settings as what I posted initially.
This one is with the skylight off:
This one is skylight on, and “affect distance field lighting” enabled on the tree instances settings under foliage.
The rest are just showing shadows…

Kind of a basic check, but have you built the project after placing your assets into it, and did you build it at production level as that may change some things. Also take a look at your engine scalability settings.

Thanks, Dotdog20, I’m definitely open to any “basic checks”; as I’m still stumbling around half-blind with this editor. Yes, I’ve “built” the scene with production level, though with dynamic lighting, it doesn’t seem to do much other than say “navigation building completed”. My engine scalability settings are all set to “Epic” for all the parameters, and resolution scale is set to 100%.

hmmm. I meant that your objects (and materials) seem completely unlit, except that they do have shadows like you’re showing in your new screenshots. That building looks like you photoshopped an AutoCAD drawing into the Kite demo. That’s not an insult, I’m just genuinely fascinated by the unintentional art direction :slight_smile:

So I would look at your materials and make sure there’s no funny business going on. Try adding some starter content or Kite demo materials onto your objects and see if they get lit differently.
I believe the biggest problem might be the sun light that is set up for dynamic and distance field lighting and all that. You should disable it and create a new default light source to troubleshoot.

You could try setting all the lights to static to see if it builds correctly and then switch them back to dynamic, rebuild, and see if that changes anything

Materials like the brick I actually took from the starter content–and modified to give it a pinkish color vs the grey it originally was. I realize my building may look like a flat AutoCAD rendering, (though I thought it was the only thing rendering half-way decent compared to the rest of the scene). What I was actually complaining about was the vegetation / trees I imported from the Kite Demo. I figured there was something wrong with my scene when mesh/materials from a “flagship” demo looked horrible. I’ve tried a new default light source, and it doesn’t seem to make much difference.

One reason I switched to dynamic lighting was because it didn’t seem to reduce my performance much, and my shadows looked so much better. After struggling with lightmap UVs on my individual meshes, resulting in shadow artifacts all over the place, I tried dynamic lighting, which seemed to work great. Once again though, my disappointment has been with the trees, grass, etc–not my building–at this point.

So this is inside the Kite Demo? Have you tried making a new project or putting it inside a different demo

No, this is not within the kite demo. I’ve done that too though, and of course things look better, except my flag (it acts quite oddly [even when applying negative values to the wind direction/speed/strength] and the shadows it casts on itself look horrible).

I set up this project from the default “blank” “new project” “Desktop/Console”, “Maximum Quality”, “with starter content”. The terrain and building I made from scratch–well the terrain is 30m SRTM data for Maui, the flora and fauna I imported from the Kite Demo.

I suppose I could try creating a new project again and import assets from this one…

Alright, I guess my shortcoming in helping you is that I don’t do much dynamic lighting. So there are probably some settings here and there in the skylight and directional light that we’re overlooking.
Have you tried turning your brightness way down in case your scene is just being overexposed like crazy?

Thanks for the suggestion StephaBon. Turning down my brightness was actually a great consideration, but it didn’t seem to make much difference–but it made me realize that especially when using a skylight, there was no need to increase directional lighting brightness–in fact I imagine it would reduce contrast at some point adding too much energy to a scene.

I tried going back to static lighting and rebuilding, but after 2 hours of sitting at 0%, the build process failed, and I got a string of errors that had to do with the foliage vertices. In any case, I don’t think static lighting is going to work for me anyway, as my project is going to involve a lot of animated objects–showing the construction of a building. I realize from this thread: that one can’t expect to get the best quality lighting when going the dynamic route. I also realized I have shot myself in the foot with the UV light mapping, as I painstakingly modified the UV maps for each mesh I imported on the second channel, but imported with the option for UE to “build” the light map–so that probably explains why I got horrible shadows no matter how big I tried scaling my maps in 3DS Max, as UE over-wrote my UVs.