Download

Out of video memory

Was working in the editor for about 4 hours today and everything was fine, then suddenly it crashed, Every time i load the level i have been building, there is the error message “Out of video memory trying to allocate a rendering resource. Make sure your video card has the minimum required memory”

Never had this issue before and cant find anything online to sort it.

My specs:

AMD Ryzen 7 1800X processor
Nvidia GTX 1060 6GB Graphics card
48Gb Vengeance Corsair RAM
1.5Tb Hard drive space

Can anyone offer any advice?

The only advice i can give you is that 6 GB isn’t a lot to work with.
If you can grab at least a 8 GB or more GPU, do it.
i switched from 4 GB to 16 GB recently and i have to say it is a lot better!
Never crash anymore because of that and you can open tons of stuff.

I’m gonna upgrade after xmas, maybe i’ll find something in a sale (or black friday). In the end i reset Windows 10, reinstalled UE4 and it’s working fine now. Must have been something corrupt in there somewhere that i couldnt find.

upgrading to top tier hardware, while good and would always help, isn’t the cause of this error. filling 4Gb+ of vram is REALLY *** hard to do, unless you randomly drag 1000’s of actors into a level and have 4k+ textures on them. i have a few 2million+ poly mesh with 32k32k **(edit: to make it more visible 32,00032,000)* textures on them, and never run out of vram on my 980ti (6gb), i also have my main game thats 8.4Km*13.7Km, single terrain with over 300,000 trees and rocks, with a sum tris count of 490,775,056. with no problems. to Fully load all that into gpu ram takes 5.55GB, but for any given part of the level it uses around 1.2Gb-2.8Gb.
it’s more likely that the video driver has some curruption and has a memory leak, this error also pops up when you run out of system RAM, even though it says GPU RAM.
case in point, when i added mixed reality support to my game, going through mixed reality portal into steam VR then to UE4, i get huge GPU RAM usage even with nothing on screen, often using 5.5Gb gpu ram on an empty test project.

**ixicalibur … you are right and you do not include the famous agp-memory from mainboard that was set by agp-aperture…and is now “automatic” …
problem of these “programmers” is the same as those “fan boys of valve-steam owner” that hardly try to copy hl… the famous steam’$ $im$ : **they use giant files with 32 bit or even 64 bit colors …with like youtube now : some 60 x2 fps… while 16bit and 25fps are largely enough and that unleash a maxi power at the GPUs … or at least is better for old “hardwares”
[that is why i also love win7 x64 : i can set video at 16 bit : 64k colors… that is not possible with win10 [32bit : 4 billions colors…] ]
there are a lot of others things than only the “use of high quality” pics… that use memory but either the bandwidths … i mean network , internet and servers…
if All servers users use giant image in 32 bit or a readable one in 16 bit…that spares a lot of bandwidth inside and outside computers , servers… so gameplay is better…
the LAG is or should be one of the most important thing to solve…
he has a Nvidia GTX 1060 6GB Graphics card with 48Gb Vengeance Corsair RAM … that is “able” to play quake 2 rtx

i have an ebay 2nd hand 1060 3Gb that can not] beside 2 rx480 … for cuda , physx… i prefer gaming with movies than having an empty VR world because all " 3d models" are too much copyrighted & locked … " Hello Mr Carmack " that stopped working for VR …he prefers Artificial Intelligence …NOW" ]

so one advices : try to reduce size & colors] of your textures… may be FileMinimizer can help you for free ;"] to reduce weight jpg is a “compressor” like 7zip… or winrar …for images it kills …]
http://www.balesio.com/fileminimizerpictures/eng/index.php

thats a really bad thing to do. the engine compresses every texture in DXT BC compression, so they all end up the same size no matter what format/size they started as. an 8k res 2mb jpeg will be the same size as a 8k res 4gb tiff once imported, both will be 85.3MB with DXT5, but the jpeg will look significantly worse.

yes in ram or directly in game folder ?] [i am not very nerd with “technicalities” : like programming : the things change so fastly :ten years ago that was targa or bmp , after jpeg , now dxt bc… that change with the hardware…] but on disk … he can also may need to compress is “giant stock of giant files”
the tool handle few formats like old good paint shop pro…that was first killer in converting files …
DXT BC compress pics a bit like FLAC with audio ? non destructive but powerfully …? good news …

I guess it matters on how complex your game is and how optimal you are with your resources to me 6GB is more then enough for certain games but UE4 is very RAM intensive which
is also one of the big reasons im not a big fan of it but again if your clever with your resources it could be delt with.

If you get this red notification message in the editor view about memory above … close windows with assets inside the editor to free up memory.

This is confusing, so is/was it my graphics card or a system error? After doing a refresh of my Windows 10, the error hasn’t come up again, but nothing has changed in the level build files at all. In fact i’ve been working on it for quite a few hours since and all is well.

The error message came up when trying to load the level. The editor would load fine, then after clicking to load my build, it crashed with the message

the word : intensive is not the best for me… as a player more than a map maker…:8 unreal is the first to no longer have to load levels… that started with batman arkham pc games long ago or so …
one tool that could be cool to find is a game engine tweaker…
finding the ini files is not so easy nor the way they are used by the game… but keys are always the same… and touch at directx or memory for some…
i did few tests with games… that can boost a lot to increase value…
so the advice to give to ben is to reboot his computer for “big testing” of a new map… video ram from card can be use by a lot of hardwares and softwares… especially a scanner or photoshop : they do not use the ram like games…

Something is wrong here regarding this. I have 24GB RAM and NVidia 1060 6GB, worked in a lot of UE4 projects before and never ever had this problem… until just now.

I’ve purchased an UE4 marketplace product so I wanted to test it. I have made new Architectural Viz default UE4 2.24 project and added new content to it.

I was able to open showcase map, everything was looking good and shaders were compiling… and at like 90% done I’ve got this message.
Started project again, this time I tried to open just a level with meshes, it opened ok but I’ve also got this error at like 90% shaders compiled.

Next time I have opened project I was not able to load any of those 2 maps as I am getting “out of memory” errors asap.

I don’t think I am actually getting out of memory (both graphic and windows) at all, something feels really bugged to me.

I have tried some solutions like increasing swap file size but nothing helped. I even made second swap file on my system disk hoping to mirracle… but nothing.

I have deleted downloaded stuff from the “content” folder and downloaded it again, but I am getting message asap now so it feels it is now “saved” somewhere.
It feels wierd that i now can’t open those maps at all.

[EDIT]
Same happened in 2.23, but I’ve managed to open the level with only meshes first.
Memory in UE4 was around 2.2GB, and graphic memory was constant 1.3GB without any spikes in memory history.

I haven’t edit my upper post just for better visibility - this is a bug and hope it is a rare one.

After migrating levels to my actual project problems dissapeared and I was able to open them normally. Actual video memory usage is 2.3GB and also normal memory usage is low so I doubt it is problem with actual memory - either graphic or swap file or something else.

Problem occured when I downloaded bought asset pack into empty and clean UE4 2.24 ArchViz project made just for this purpose. This can be important info for a future reference.

UE4 has really “weird” VRAM usage. If you paint/sculpt landscape, the data fill the VRAM until you do a “save all” instead of using RAM.
There’s absolutly no “out of video memory” protection, meaning that if you paint/sculpt your landscape until VRAM is full, it will simply crash instead of stopping filling the VRAM and warn you that it can’t write anymore because memory is full, or autosave data to disk (like windows virtual memory swap file) or even simply transfer data to RAM.
And it’s like this for every other data.

Unreal engine editor is the ONLY of every software I’ve ever used that act like this, crashing because unable to manage memory.
Crashing because the editor fill your 8GB VRAM and trying to write more data to VRAM, while only 20% of your 32GB memory are used is really disappointing for a professional software.
RAM is cheap, GPU with more than 8GB is really expensive. A GPU with 16GB VRAM is 2500$
And YES, you can easily fill 8GB VRAM while working on large landscapes with large textures.

Just a thought to the discussion:

Every UE4 release is tested over the current GPU driver available for all brands (ie: AMD, NVidia, Intel) at the launch date, so if you are using a driver version dated before that specific UE4 release, it might show issues. You might want to use the available driver version at the UE4 release date if there is no issues, update until you find a release which introduces bug (with luck no bugs will be found).

Another thing to think about is if your motherboard is using the latest BIOS released and if your GPU is also with the latest firmware for the model you got.

With those above, you will still need to be sure Windows is updated aswel.

All these pieces of software are layers that might interfere directly with UE4.

It’s not an hardware/third party software issue, it’s because how the UE4 editor works.
Use a monitoring tool like RivaTunerStatistic or any other software which can show your VRAM usage. Now create a landscape and start sculpting it. The data will fill the VRAM instead of the RAM and the VRAM won’t be cleared until you save your level.
If you don’t save before your VRAM is full, it will simply crash without any warning, even if you have 32GB of RAM and 90% of it free.
Drivers have nothing to do with that. The protection for VRAM overload is simply not coded and VRAM is used by the editor to store data that don’t need to get fast access for the GPU

Your conclusion might be correct. You should try test the new release 4.25 to see if there were any improvements or if it got worst. Unfortunately, the changes with the release would be hard to propagate for your release, via changes in source and rebuilding, since it is connected with several new features added to UE4. Just another thought.

I get this same error in 4.26.2 when building reflection captures for my level… Using 2x RTX 3090s in nvlink… 24gb ram each … This is a major bug in the engine and I can see it has never been addressed.

I am running a 2 x RTX 3090 48GB nvlink, Threadripper 3990X, and 128GB RAM but still having this same error in 4.26 while executing a dataprep recipe for a 300mb datasmith model. It doesn’t seem to be an issue with my hardware.