Download

Out of Memory Problem PLEASE HELP!

In the launcher click on “Add Version” and select 4.8.3 :slight_smile:

I bought 32GB earlier for development which was perfect since our project is huge and I hate to turn off other softwares while working, but really 16GB should be fine for most. Now I have 64GB though but that’s only because I retired a server I was using that had 32GB ram as well, figure I might as well use it instead of putting it away. I tend to get use for that when I do some incredibly ram heavy tasks, but not in Unreal Engine, so that’s pretty much a waste for most. Go with 16GB or 32 at most.

This may sound like Cpt. Obvious here, but are you sure you’re not using gigantic textures for your models? Many commercial models come with super highres textures and expect the buyer to scale down their size to what they really need

This worked! I was able to create a lot more. I did end up having the same problem again but I did manage to add more rooms thanks!

How big of a world are you developing? I’m going to get 16GB but I’m topping off at 8GB with only 4 rooms. 16GB would give me 8 rooms?

Please let me know how I can check for that. Thanks in advance.

I just got a warning message saying my video memory is low. I lowered the quality from “Epic” to “Low” on all categories using the settings. Using NVIDIA GeForce GTX 750 Ti, at the lowest possible quality - 2GB isn’t enough?

Hi

I just got this. Please help! I feel like I’m giving you guys a headache, but I really need this to work.
GC.jpg

nVidia cards don’t use AMD drivers, that error suggests you are using your Radeon GPU rather than the nVidia and likely points to why your boxes had jagged edges. Also if your onboard radeon is selected as the main GPU it would help explain the low memory problem as it shares system memory.
Just a thought, check the back of the case and see which outlet your monitors plugged into, it should be the one attached to the vid card, but sometimes people get a little mixed up and plug it into the onboard one instead.

Well, when you doubleclick on a texture in the UE it gives you the size of the texture and also the source path. If the size is way greater than what you need, go to the source location, and reduce the size with Paintshop or so and then reimport the texture. Be sure to have a backup of the texture :smiley:

one of the epic devs said he uses the same GPU and that it works well with UE4, also 2GB should be enough for most things you would want to do in UE4.

based on that warning your getting it does look like you aren’t using your nvidea card because as Linz pointed out its not AMD and taking that and your poor performance into account it looks like you might be using the integrated GPU, maybe you should check all your connections and whether all your devices/drivers are working properly.

  1. Video Memory (VRAM)
    The conflict with onboard graphics seems most likely, I think the OP needs to ensure the AMD GPU is totally disabled (usually in the BIOS - put the discrete GPU in first before disabling!) and do a fresh install of Nvidia drivers (fresh install of Windows would also be good assuming the AMD GPU is totally disabled in BIOS):
    http://www.tomshardware.com/answers/id-1708507/disabling-apu-graphics.html

  2. Computer Memory (RAM)
    As for 8GB RAM, yes that can run out very fast nowadays. Adding RAM to get 16GB of RAM is good. However, also check that you are not running out of SWAP disk as well (Virtual Memory). I have 16GB of RAM and I set 16GB of swap on my SSD and that keeps things ticking. When I set the swap to 8GB, even with 16GB of RAM I get low memory warnings with 2 projects open, some big Lightmass baking going on, browsers, other apps, etc.

I don’t think it scales in that way in terms of “rooms”. If you have an example asset from the Marketplace maybe ask guys with 16GB of RAM and at least 16GB of swap (Virtual Memory) to test that asset. In my configuration of 16GB RAM and 16GB swap I can load, edit, lightmap, render realtime at 1080p and render frame-by-frame at 4K the Elemental Demo and Landscape Mountains asset. Realtime speed is slow of course as it’s just an Nvidia 660M (gaming laptop).

I’m tempted to try the Kite demo but that is a monster so maybe another time.

I uninstalled my AMD Driver, I’m going to check if that did the trick. How do I tell the system to use my Nvidia? Does that mean I have to get a Intel processor? Because AMD doesn’t use Nvidia cards?

It says Nvidia is working properly, how do I use my nvidia card? Everything shows me that I’m using Nvidia but I still don’t notice a difference in graphics let alone the memory problem that I have. (I’m starting to get really frustrated, we are coming up on 6 days now)

Take a look in the log files for your project (Should be <ProjectDir>\Saved\Logs). Looks for lines like the following (should be near the top of the log):



[2015.08.22-09.37.47:042]  0]LogD3D11RHI: Found D3D11 adapter 0: NVIDIA GeForce GTX TITAN X (Feature Level 11_0)
[2015.08.22-09.37.47:042]  0]LogD3D11RHI: Adapter has 12176MB of dedicated video memory, 0MB of dedicated system memory, and 16314MB of shared system memory, 1 output[s]
[2015.08.22-09.37.47:047]  0]LogD3D11RHI: Found D3D11 adapter 1: Intel(R) HD Graphics 4600 (Feature Level 11_0)
[2015.08.22-09.37.47:047]  0]LogD3D11RHI: Adapter has 112MB of dedicated video memory, 0MB of dedicated system memory, and 16314MB of shared system memory, 1 output[s]
[2015.08.22-09.37.47:048]  0]LogD3D11RHI: Found D3D11 adapter 2: Microsoft Basic Render Driver (Feature Level 11_0)
[2015.08.22-09.37.47:048]  0]LogD3D11RHI: Adapter has 0MB of dedicated video memory, 0MB of dedicated system memory, and 16314MB of shared system memory, 0 output[s]
[2015.08.22-09.37.47:048]  0]LogD3D11RHI: Chosen D3D11 Adapter Id = 0


and see what adapter is actually being chosen.

Our world is pretty large, around 50 square kilometers. You could definitely do more than 8 rooms with 16GB RAM. Like I said, you’re most likely spending most of your 8GB on running the engine + windows and any other softwares you haev running at the same time, your room probably only use a fraction of that, so double amount of rooms won’t mean you need double amount of RAM, since you won’t be running the whole engine and windows once for each room : )

The AMD chip you have is a CPU+GPU.

You want to disable the AMD GPU not the AMD CPU. You want to keep the AMD CPU and use the Nvidia GPU.

Do you see an option in the BIOS to disable the AMD ~GPU~?

Guys thank you all, you guys helped me out more than you know! I have fixed the problem, I got 16GB and I disabled AMD GPU. My 2GB Graphics card is able to hold everything now, looks like the system was reading my Radeon GPU. Can’t thank you guys enough.

Awesome! :slight_smile:

Great to hear! :slight_smile: Good luck with your project!