Other compilation error(5)

When i try to bulid pone tutorial(https://docs.unrealengine.com/latest/INT/Programming/Tutorials/PlayerInput/2/index.html), it causes errors like this.

error code: OtherCompilationError (5) D:\unreal\tutorial\ponetutorial\Intermediate\ProjectFiles\Error ponetutorial

error MSB3073: The command ““C:\Program Files\Epic Games\4.9\Engine\Build\BatchFiles\Build.bat” ponetutorialEditor Win64 Development “D:\unreal\tutorial\ponetutorial\ponetutorial.uproject” -rocket -waitmutex” exited with code -1. C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 38 5 ponetutorial

how can i solve this?

i’m using unreal engine 4.9.2, win10 64bit,Visual Studio community 2013

Try deleting the Intermediate folder.

i deleted the Intermediate folder in my project and vb2013 caused load failed.

Having the same problem, and it happens in all of my projects o.O

Hello ssowhats,

First, if you deleted your intermediates folder, you’re going to need to right-click the .uproject file and Generate Visual Studio Project files to restore the intermediates folder as they are required. After that, please try compiling your project again. If you still receive the “Other Compilation Error (5)” message, then please look at the Output tab instead of the Error List tab. This message means that the compilation error that is occurring is something that the program doesn’t have an error message set up for but you can still see the details of what the problem is in the Output tab.

If you’re still having issues after reading the Output, please copy and paste the Output here and I can try to assist your further.

hello ,
i have the same problem. i deleted the intermediate folder but still getting the same problem ,
output window shows the following message

2> Running UnrealHeaderTool “G:\Unreal Projects\CodeStudy\CodeStudy.uproject” “G:\Unreal Projects\CodeStudy\Intermediate\Build\Win64\CodeStudyEditor\DebugGame\UnrealHeaderTool.manifest” -LogCmds=“loginit warning, logexit warning, logdatabase error” -rocket -installed
2> G:/Unreal Projects/CodeStudy/Source/CodeStudy/PickupActor.h(28) : ‘BlueprintCallable’ is only allowed on a property when it is a multicast delegate
2>Error : Failed to generate code for CodeStudyEditor - error code: OtherCompilationError (5)
2> UnrealHeaderTool failed for target ‘CodeStudyEditor’ (platform: Win64, module info: G:\Unreal Projects\CodeStudy\Intermediate\Build\Win64\CodeStudyEditor\DebugGame\UnrealHeaderTool.manifest).
2>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command ““G:\unreal engine\Epic Games\4.9\Engine\Build\BatchFiles\Build.bat” CodeStudyEditor Win64 DebugGame “G:\Unreal Projects\CodeStudy\CodeStudy.uproject” -rocket -waitmutex” exited with code -1.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 1 skipped =========

please help me i tried a lot

Hello streak_light,

Can you post the line of code at line 28 in your PickupActor.h? The compilation error is pointing towards that line. Posting the lines around that would be helpful as well, to give context.

hi Matthew,
this is my 28th line oh PickupActor.h

private:

// static mesh to allow pickup 

UPROPERTY(EditAnywhere, BlueprintCallable, category = "pickup", meta = (AllowPrivateAccess = "true"))

class UStaticMeshComponent* PickupMesh ;

looks like the BlueprintCallable property has to be multicast delegate but i don’t know how to define a property as multicast delegate ,

For a UPROPERTY, you would want BlueprintReadOnly or BlueprintReadWrite. BlueprintCallable is for a UFUNCTION declaration.

1 Like

thanks a lot it worked , now i know i have to read carefully about all the blueprint functions.

I’m having this problem as well. I regenerated my intermediates folder, recompiled, but it failed again because of an error within the standard Actor.h class:

CompilerResultsLog: Info C:/Program Files (x86)/Epic Games/4.12/Engine/Source/Runtime/Engine/Classes/GameFramework/Actor.h(461) : Unrecognized type 'UChildActorComponent' (in expression TWeakObjectPtr<UChildActorComponent>) - type must be a UCLASS

Is there any way to tweak the code so it works or do I have to reload the class code somehow?

Yes, you need to regenerate solution after that.

Hello ViolinRobot,

Can you please make a new post about this issue? This is an old post and the “other compilation error(5)” message is a very broad error message for when the compiler doesn’t have an error message related to the problem.

i have a problem…

D:/Documents/Unreal Projects/GoldenEgg/Source/GoldenEgg/NPC.h(15): error : Missing ‘*’ in Expected a pointer type
2>EXEC : error : UnrealHeaderTool failed for target ‘GoldenEggEditor’ (platform: Win64, module info: D:\Documents\Unreal Projects\GoldenEgg\Intermediate\Build\Win64\GoldenEggEditor\Development\GoldenEggEditor.uhtmanifest, exit code: OtherCompilationError (5)).

thank you for attention

"D:/Documents/Unreal Projects/GoldenEgg/Source/GoldenEgg/NPC.h(15): error : Missing ‘*’ in Expected a pointer type "

It looks like you’re missing a * on this line.