[OSX] Editor hangs at 0% on launch

My editor hangs when compile my project for the game I’m making. It stays at 0% the whole time. I’ve verified the installation, I deleted my binaries folder, I’ve cleaned the project before building, but still hangs at 0 percent. Below is the output from building the project

[2016.02.16-22.40.25:420][  0]LogInit:Display: Running engine for game: PS
[2016.02.16-22.40.25:420][  0]LogPlatformFile: Not using cached read wrapper
[2016.02.16-22.40.25:420][  0]LogInit:Display: RandInit(1360175059) SRandInit(1360177523).
[2016.02.16-22.40.25:420][  0]LogTaskGraph: Started task graph with 4 named threads and 7 total threads.
[2016.02.16-22.40.25:420][  0]LogStats: Stats thread started at 0.132863
[2016.02.16-22.40.25:420][  0]LogInit: Version: 4.10.2-2818068+++depot+UE4-Releases+4.10
[2016.02.16-22.40.25:420][  0]LogInit: API Version: 2758231
[2016.02.16-22.40.25:420][  0]LogInit: Compiled (64-bit): Jan  6 2016 18:48:53
[2016.02.16-22.40.25:420][  0]LogInit: Compiled with Clang: 7.0.0 (clang-700.0.72)
[2016.02.16-22.40.25:420][  0]LogInit: Build Configuration: Development
[2016.02.16-22.40.25:420][  0]LogInit: Branch Name: ++depot+UE4-Releases+4.10
[2016.02.16-22.40.25:420][  0]LogInit: Command line:  -NSDocumentRevisionsDebugMode YES
[2016.02.16-22.40.25:420][  0]LogInit: Base directory: /Users/Shared/UnrealEngine/4.10/Engine/Binaries/Mac/
[2016.02.16-22.40.25:420][  0]LogInit: Rocket: 1
[2016.02.16-22.40.25:449][  0]LogInit: Presizing for 0 objects not considered by GC, pre-allocating 0 bytes.
[2016.02.16-22.40.25:456][  0]LogInit: Object subsystem initialized
[2016.02.16-22.40.25:458][  0]LogInit: Selected Device Profile: [Mac]
[2016.02.16-22.40.25:458][  0]LogInit: Applying CVar settings loaded from the selected device profile: [Mac]
[2016.02.16-22.40.25:469][  0]LogInit: Computer: J-Plos-MacBook-Pro.local
[2016.02.16-22.40.25:469][  0]LogInit: User: plot
[2016.02.16-22.40.25:513][  0]LogInit: CPU Page size=4096, Cores=4
[2016.02.16-22.40.25:513][  0]LogInit: High frequency timer resolution =1000.000000 MHz
[2016.02.16-22.40.25:513][  0]LogInit: Power Source: Battery Power
[2016.02.16-22.40.25:513][  0]LogInit: Memory total: Physical=16.0GB (16GB approx) Pagefile=0.0GB Virtual=16.0GB
[2016.02.16-22.40.25:518][  0]LogTextLocalizationManager: No specific translations for ('en-US') exist, so ('en') translations will be used.
*** Recognized (0x65) family*** (20 cols X 12 rows) using raw16bitRange= 512, thresh8bits=  3, zsignal_per_pixelsum= 41

When I try to open other projects form the launcher the editor still hangs at 0%.

Any ideas on how to fix this?

What fixed this. A clean install where I deleted all the folders/files listed here: How do I uninstall UE4 on a Mac? - Installation & Setup - Unreal Engine Forums