OSX - Anyone know how I can get the engine running again?

The editor no longer launches at all and i get a crash report link text
i tried reinstalling the editor and tried reinstalling the launcher this hasn’t worked
any help would be very much appreciated

Seems like you were too fast upgrading to Yosemite, which could be causing some incompatible issues with UE4, as it’s still fairly new. I believe Apple is already gearing to release some fixes for it, too.

If you can go back to Mavericks, that would be a good starting point to troubleshoot the issue, or if you know you had no problems with Mavericks. Being an early adopter is always a tricky affair…

Yes, but if the upgrade caused this there’s little that can be done until Epic runs Yosemite through QA and then fixes whatever incompatibilities exist with UE4.

This means you might have down time meanwhile. Perhaps someone from Epic will chime into this error and have a better resolution - sorry I don’t run Yosemite, still using Mavericks.

Hey Amigo, thanks for reponding but i can’t revert back on my macbook as its quite new and has been running fine for nearly 3 weeks

although it may be i don’t feel that Yosemite is the cause of the problem, i only started experiencing crashes when i changed the hud to a UMG widget in one of my projects. the more work i did in the widget the more the engine crashed to the point where 4.5.1 will not launch at all, not even to start a new project, I’ve tried manually removing and reinstalling both the launcher and 4.5.1 and still the same crash at launch. i did however just install 4.4.3 and that launches fine but that no good to me as my projects are all now 4.5.1

as always with UE4 bugs nothing really makes sense to me but i have found that when lunching the editor switches the MacBooks graphics from Iris pro to the 750M and 4.5.1 crashes but 4.4.3 doesn’t. so yet another work around i have to disable switching and set the graphics to the 750M before running the engine.

Seems like that graphics enumeration/detection is quirky, or code has changed between 4.4 and 4.5.

Are you running gfxCardStatus (https://gfx.io/) to switch graphics (or is that not available for Yosemite)?

i used energy saver setting in system preferences but just downloaded what you’ve suggested and thats better for quick access ill be using that till the bug is fixed. still doesn’t make sense as to what caused it think maybe the last launcher update.
Thanks for the link pal

i can now confirm that this bug is not an issue with 4.6 but still is with 4.5.1