OSVR and UE4 on linux

Sorry Ronir. I have a related question to ask you. Have you been able to successfully get the steam controller plugin to work on Linux? I tried it way back in version 4.8 and it wouldn’t even load the editor once I installed the plugin. I had to uncheck the plugin and re run my project.


I built a simple project (basically the initial plane that somes with a blank project…) with OSVR plugin enabled.
It works fine when I package for windows, OSVR is connected and responsive.
But when I run it on Linux (after packaging with the cross compilee for linux arm64), it runs and is responsive with the mouse cursor, but not with the OSVR.
I’m using UE 4.15 from source, with the built-in OSVR-Plugin that comes with it, and when I run the game on Linux, there’s no connection to the OSVR Server (at least no prints from the OSVR server that a connection was made).

Am I doing something wrong or is the there no support for Linux for the OSVR-Unreal plugin?

It doesn’t have linux support. Follow this pull request: Linux support by janoc · Pull Request #123 · OSVR/OSVR-Unreal · GitHub